About the "atmloc.f" usage

Dear FLUKA users,
I want to use the GCR tools to run a cosmic rays simulation. But something strange happend when I run the executable rountine.
I used the “lfluka -o exeatmloc atmloc.f” command to build the executable file. Then I run it. After entering the geographic coordinates, altitude and cut-off acceptance, the run stoped without any files like “atmloc.geo” created or ask for more parameters as expected.
Besides, when I run the “atmloc” from …/fluka/bin/ directly, the same thing happend.
Was there something wrong or I misunderstand?

Dear Shan Jiang,

I’m not an expert with the GCR simulations in FLUKA, but as far as I can tell, the selected 11.4 GeV cut-off acceptance is to large to create the localized geometry.

You can try to reduce the value, or use the global Earth geometry usually available at /usr/local/fluka/data/gcr/atmogeo.cards


Thank you, sir.
The cut-off value 11.4 was picked from the SPECSOUR card in the gcr example input file from /fluka/examples/gcr/AllParticleExample/ , and the geographic coordinates were from the input too.
While setting the cut-off as 5 GeV, it created the atmloc.geo and other files. It looks like I need to learn more about the cut-off acceptance.
Thanks for your help :slight_smile: