Flair error: Assertion FAILED on BEAMAXES card

From “Ubuntu 18.04 LTS” terminal I entered “flair stopper.inp &” and got a bunch of fatal messages:

ERROR: Assertion FAILED

regarding the BEAMAXES card (below):

BEAMAXES , 0.999194, 0.0, 0.040132, -0.040132, 0.0, 0.999194

Never had this problem running stopper.inp with FLUKA2011. Maybe a bug in Flair?

Dear Walter,

Flair 3 checks if the length of the vectors specified on the BEAMAXES are one with a precision of 1\cdot10^{-10}.

You just need to increase the digits for each number, for example:

* ..+....1....+....2....+....3....+....4....+....5....+....6....+....7..
BEAMAXES   0.9991944       0.00.04013179-0.0401318       0.0 0.9991944

Or you can use Flair expression to make Flair calculate the trigonometrical functions for angles, like cosBxx = cosd(2.3). See the F3.6 section of the Flair manual (F1 key on the keyboard).

Cheers,
David

Tried that. In fact, increased everything to EIGHT figures

BEAMAXES , 0.95105652, 0.0, 0.30901699, -0.30901699, 0.0, 0.95105652

and I still get a RED message (not a warning

Dear Walter,

in Flair you can use even longer numbers to satisfy the accuracy check, like
cosBxx: 0.9510565162951535

(of course this won’t be included in the FLUKA input file unless the FREE format is activated, but it is not necessary to do as FLUKA will take care of the normalization of the length)

Cheers,
David

I have tried increasing the numbers to 8 significant figures, namely,

BEAMAXES , 0.95105652, 0.0, 0.30901699, -0.30901699, 0.0, 0.95105652

but I still get the same RED message

e> ERROR: Assertion FAILED

I also tried (with with both tud800.inp and with tud800.flair)

BEAMAXES , cosd(18.) 0.0 sind(18.) -sind(18.) 0.0 cosd(18.)

as well as

BEAMAXES , =cosd(18.) 0.0 =sind(18.) =-sind(18.) 0.0 =cosd(18.)

with the same error messages.

Very frustrating, since I know that this choice of BEAMAXES worked perfectly with FLUKA2011. Need some more help, svp. Thx, Walter

Dear Walter,

in Flair you can use more than 8 digits to have higher accuracy.

But it is strange, that it doesn’t work with the expessions [=cosd(18.)]. Can you confirm which Flair version do you use? How do you edit your input files? With Flair, or with a text editor? Also, could you share an input where you get the error message?

Cheers,
David

Still having the RED error messages.
Flair version: 3.1-2
FLUKA version: 4.0
Use TextPad 8 as my editor of choice
Do not yet know how to share my input file (attachments?)

But FLUKA runs to completion and the results are the same as with FLUKA2011.

Ralph

Dear Ralph,

based on the text editor I assume you are using FLUKA and Flair via WSL and Xming on Windows.

With Xming Flair doesn’t recognize file changes made by an external text editor. Please try to edit the cards inside Flair.

You can attach files to a post with the Upload button located above the text input field.

Cheers,
David

Please see attached .inp file (renamtud800.inp.txt (39.4 KB) ed .inp.txt for transfer).
Don’t know if this will work. Might have to drag it from Flair.

Dear Ralph,

I modified your input, by adding more digits to the numbers on the BEAMAXES card, now there shouldn’t be any assertion error.

tud800_fix.inp (39.5 KB)

There was also an error with a PHYSICS card, setting the maximum energies for the PEANUT model. I simply disabled this card, since PEANUT is used up to 100 TeV by default.

Cheers,
David

Hi David
You are correct. I am using FLUKA and Flair via WSL and Xming on Windows 10.

Also, entering trig values out to 12 decimal places solves that problem.

And the easiest way to Upload an attachment is to drag it to this message window (note: just temporarily add .txt after the .inp to satisfy the rule).

Thank you, Ralph Nelson