Flair V3.1-15, fonts look terrible

Ubuntu 20.04, python 3.8.8.

Flair recently changed to version 3.15, dated 21-Oct.

Now, the fonts look “terrible”. But if I run as sudo flair they look OK.

Any suggestions?


Carl Ross

Dear Carl,

How did you update Flair, via sudo apt update / upgrade, or via downloading the compressed source?

What do you see in $HOME/.flair/flair.ini (with and without root privileges)?


I think flair is updated by the ubuntu package manager. Every so often there is a message saying various updates are available and I just click OK.

Since then, I have tried sudo apt update / upgrade but still the same result.

So in flair.ini I see (for the fonts)

tree = times,10,bold,roman
title = times,10,bold,roman
balloon = times,10,bold,roman
ribbon = times,10,bold,roman
ribbontab = times,10,bold,roman
input.comment = times,10,bold,roman
input.fixed = times,10,bold,roman
input.hidden = times,10,bold,roman
input.label = times,10,bold,roman
input.tag = times,10,bold,roman
input.value = times,10,bold,roman
manual.title = times,10,bold,roman
manual.default = times,10,bold,roman
manual.fixed = times,10,bold,roman
TkDefaultFont = times,10,bold,roman
TkFixedFont = times,10,bold,roman
TkMenuFont = times,10,bold,roman
TkTextFont = times,10,bold,roman

which was my attempt to get something that looks not bad.

I don’t know where to find the .ini when I do sudo? I do note that under Config I have a much wider range of font choices.




For another application, I recently had occasion to install anaconda.

I see online comments regarding python-anaconda-fonts.

I don’t have enough insight to know what to try.



What happens if you try to replace the [Font] section in $HOME/.flair/flair.ini by:

tree = Sans,11,normal,roman
title = Sans,12,bold,roman
balloon = Sans,10,normal,roman
ribbon = Sans,-11,normal,roman
ribbontab = Sans,-14,normal,roman
input.comment = Mono,11,normal,roman
input.fixed = Mono,11,normal,roman
input.hidden = Sans,10,normal,italic
input.label = Sans,10,normal,roman
input.tag = Sans,12,bold,roman
input.value = Sans,11,normal,roman
manual.title = Sans,16,normal,roman
manual.default = Sans,11,normal,roman
manual.fixed = Mono,11,normal,roman
TkDefaultFont = Sans,10,normal,roman
TkFixedFont = Mono,10,normal,roman
TkMenuFont = Sans,10,normal,roman
TkTextFont = Sans,10,normal,roman

Then restart Flair?

Maybe you have a selection of fonts somehow not available without root privileges, if you do:
fc-list > all_fonts.txt
fc-list > sudo_all_fonts.txt
diff all_fonts.txt sudo_all_fonts.txt
What do you get?


So if I compare the two font lists many differences show up; more than 1000 lines.

On further digging this seems to be a known problem with anaconda:

Another application required me to install anaconda and I didn’t realize it would take me down this rabbit hole.

If I go back to native python all is well with flair. It was wrong on my part to immediately blame the problem on a flair update.

Thanks, Carl

Dear Carl,

Ok, great!