Isotopes yield calc

Hi! I want to calculate yield of isotopes of which produced when some element irradiated by gamma- or some other type of radiation. Can anyone please show some example code with such task ?


The attached input file gives you a very simple example of how to assess the isotopes produced by irradiating gold with mono-energetic photons. Please refer to the manual for details on the units and the semi-analogue mode for the RADDECAY card or the units of the output from the RESNUCLE card. If you have e.g. a specific photon spectrum in mind, you can use the source.f routine or if you have some specific irradiation and/or cooling time you can do that with the IRRPROFILE and DCYSCORE cards.


20200206_isotope_production_gold.inp (1.7 KB)

1 Like

When I try to run this example there is nothing happened. And when I close the program there appears next message. What is the problem ?

Version : 3.0-5
geoviewer : 3.0-5 False
Revision : 6179dbf6
Last Change : Tue Jan 21 22:26:48 2020 +0100
dicom : 1.2.1
numpy : 1.16.2
kleidi : 1580843761.300
Platform : linux
Python : 3.7.3 (default, Oct 7 2019, 12:56:13)
[GCC 8.3.0]
TkVersion : 8.6
TclVersion : 8.6

Traceback (most recent call last):
File “/usr/local/flair/”, line 1212, in call
return self.func(*args)
File “/usr/local/flair/”, line 988, in execute
rc = self.startRun(run)
File “/usr/local/flair/”, line 1016, in startRun
rc = run.start(output=log)
File “/usr/local/flair/”, line 1571, in start
errors = self.project.writeInput(self, cwd, defines)
File “/usr/local/flair/”, line 3975, in writeInput
for n,v in defines:
TypeError: ‘NoneType’ object is not iterable

Thanks for the bug reporting. I just fixed it.
Actually the run takes place and for some reason it fails to attach to the run to show the process. If you click the Attach button then it attaches and works.

Anyhow it is fixed on the new release I will upload on the site quite soon.

I can’t find Attach button. Where it is located ?

Hi @sergey.a

Indeed, I ran the example I sent you on FLUKA for docker and therefore not with the latest version of Flair. Thanks @vasilis for bug fixing.


It seems I found Attach button. But when I clicked it there was changed nothing. The situation is still the same.

I’ve just uploaded a new minor release of flair, that should correct this one and several others.
Could you please try it?

I’ve ran this input. Here is one of output file. Can you tell please where there are written the numbers of isotopes producing in gold during it’s irradiation ?

20200206_isotope_production_gold(1)005.out (94.2 KB)

Hi @sergey.a

You’ll find the number of produced isotopes in a readable for the two .lis files that are produced when processing the results of the simulation in flair (in the ‘Run’ tab, under ‘Data’). You can also directly plot the activation products in flair (look for ‘Resnucle Plot’ in the Flair manual).


Are .lis files produced in the same folder where .inp file is located ?

Tell please where can I find Flair manual ?


The FLUKA manual available at:

1.) On the FLUKA website: FLUKA Manual
2.) In you FLUKA installation, in the docs subfolder.
3.) In Flair. To open it hit the F1 key, or type fm in the terminal.


The “flair” manual is also available on the web

After run I’ve obtained five _fort.31 files. Tell please what means these numbers in this file.

20200206_isotope_production_gold(1)005_fort.out (51.5 KB)


The depending on the unit of your scoring card, the _fort. files contain the results of each cycle in binary form. To get the results in more human readable form you need to post-process the simulation results. In Flair this is done easily with the ‘Process’ button, which will also merge the results from all cycles for you. You’ll find useful information on this in the Flair tutorial or in the FLUKA manual.