Again on block of geometries

Dear Vasilis,
sorry to bother you again on the same topic. I tried to add three include instructions, as you suggested, to import a simple block of geometry inside another but there is some problem.
You find in attach all the files (.out added in order to upload).
This is the error message

Started 2020.01.16 16:40:12
e> ERROR: Region ‘vacuum’ What=-1 Type=expr: region expression: + intersection, - subtraction, | union, (…) parenthesis allowed
Invalid body ‘cont’
e> ERROR: Region ‘vacuum’ Region vacuum invalid token: cont

So the imported container can’t be subtracted from the main sphere because the cont body is not available. The first include instruction (#include prova2.bodies) is processed in a way don’t understand because I can’t see the included bodies in geometry editor neither in the input file. Moreover, in other attempts I see that Flair sometime actually rewrites the content of the included files, erasing their content or writing a minimal input file inside prova2.bodies. In the latter case closing and reopening Flair and prova1.flair, prova 2.bodies as an input file is incorporated in the main prova1.inp cutting out all remaining cards (other regions definition and assignment). I also noticed that often the instruction #include prova2.bodies is completed by Flair with a #endinclude instruction.
I tried to add #endinclude by hand in the main input for all the include files but with no results.
Could you please point out any mistake I made or provide a minimum working example?
prova.tar.xz.out (932 Bytes)

Thanks @michele for reporting it. It was a bug in flair with the correct use of #include files. Now it is corrected. You can install the 3.0-3 version that solves the problem.
Please note that it would be better to remove your prova1.flair" file and start from the input to create a correct prova1.flair
flair prova1.inp

Dear Vasilis,
I tried to install the new flair 3.0-3 rpm version (I’m a fedora 31 user) both updating the packages and erasing and re-installing flair and geoviewer, but I did’nt noticed any difference with respect to the 3.0.
I also installed the ubuntu debs packages (18.04 and 19.10 on virtual machines) and the issue with the rewriting of .bodies .regions and .cards files is solved, but still the container region is not recognized. The attached picture shows that bodies measures are not assigned to the proper WHAT (parsing problem?)

Hi @michele,

is this happens also if you delete the *.flair files, and then open prova1.inp?


Hi @horvathd,
thank you for the reply. Actually I just opened the input file with the command flair prova1.inp as suggested by Vasilis but without deleting the .flair. After opening, I saved the .flair again and I thought it coulb be enough.
This solve the problem for rpm and deb, now all works as expected.
Thanks again to you and Vasilis!