Cannot load RT_structure in Flair

Dear FLUKA experts,
I am studying the medical application of Fluka. Fortunately, after studying some lectures, I successfully generated .vxl file and imported RTPLAN and RTDOSE in flair. But I encountered a problem when I tried to load RTstructure. As shown in the figure, I can’t find RTstructure, meanwhile, the other three were successfully loaded. I will upload all my files, please help me check the problem.


Its unclear for me why it didn’t show the RTSTRUCT.
Permission problem?

When I opened your files in my computer they appeared correctly.
Please take this flair file, which is the one you send with the addition of the RTSTRUCT pointer inside

rt_test.flair (2.0 KB)

Hi @vasilis ,unfortunately, it still hasn’t been loaded after I updated the software and used your new files. I don’t know what permissions limit my to load RTSTRUCT. It should be loaded in Dateset, under normal circumstances, just as RTDOSE and RTPLAN, right?
Perhaps you have any other ideas I can try to solve the problem?

Dear FLUKA experts,

I haven’t solved the above problem yet.
1.If possible, I would like an example to test.
2.How should I define the structure now?
This is particularly important to me.

Dear @nostaaal
can you please verify that you have the latest version of flair?

Hi, my flair version is 3.2.4, and I successfully loaded RTSTRUCTURE by a new CT, the difference between the two is shown in the following figure. I don’t know if this is the key to the problem, because the previous CT , RTDOSE and RTPLAN can be loaded normally, while RTSTRUCTURE cannot be loaded, but both of them have the same “Specific character set”.

Thank you for the information. If the character set was the problem, maybe you could try to change the locale variables before launching flair as

export LC_ALL=C.UTF-8

to check

Fortunately, RTSTRUCTURE can be loaded normally after I anonymize it.