Can't Setup FLUKA to FLAIR

Hello everyone,

I’m fairly new to fluka and flair and albeit having read the documentation available, I’m having trouble to simply “find the executable”:

When I boot flair, appears a yellow error message box stating:

Warning FLUKA executable not found
Cannot find FLUKA executable 'fluka
Please set the correct FLUKA directory in Preferences

The problem is that I already have installed fluka and have the flukahp and flukadpm executables, but after selecting one or the other - in Preferences > Program - and clicking OK the same error message appears. In a desperate attempt, I even tried renamed “flukahp” to be “fluka”.

In Preferences > Fluka Directory, I selected the file that contains all fluka related files - which is where I unpacked the tar.gz (downloaded from And this path is the same I defined FLUPRO with (export $FLUPRO=/…/fluka/), so there isn’t even any incoherence on that regard.

My gfortran is updated.
I’m running a Ubuntu 20.04.

If someone could help, I’d deeply appreciate, since I’ve been struggling with this for quite some time.

Stay Safe,
All the best,
João Azevedo

Dear João,

Welcome on the forum!

Unfortunately, we can only provide support here for the FLUKA released by CERN at, and Flair

If you encounter any issues with these versions, please let us know.


A post was split to a new topic: Donwload problem