Disc full in a fedora 32 machine hosted on Cloud

Dear All
I hope everybody is doing well! I have this simple problem for which I am not sure where to go for answers. So, I am posting it here. I run fluka on a fedora machine hosted on Cloud service in our institute. The fedora machines are modest- 4 GB RAM, 20 GB hard drive. The output of various commands attached below lists these values.
The problem is that when I run a simulation with say 100 or 200 cycles, the disk space fills up and the fluka process is terminated. This is not a problem as such but then I have trouble accessing the machine hosted on cloud. So, is there a way to tell FLAIR to stop the run/cycle when say about 90% of the hard drive is filled? Apologies for stupid question.

[mukherjees@instance-03001261 ~]$ df -H
df: /run/user/12274/doc: Operation not permitted
Filesystem               Size  Used Avail Use% Mounted on
devtmpfs                 3.1G     0  3.1G   0% /dev
tmpfs                    3.2G     0  3.2G   0% /dev/shm
tmpfs                    3.2G  1.3M  3.2G   1% /run
/dev/mapper/fedora-root   18G   13G  4.7G  73% /
tmpfs                    3.2G  4.1k  3.2G   1% /tmp
/dev/vda1                1.1G  243M  711M  26% /boot
tmpfs                    623M   46k  623M   1% /run/user/12274
[mukherjees@instance-03001261 ~]$ nproc
[mukherjees@instance-03001261 ~]$ grep MemTotal /proc/meminfo
MemTotal:        6077308 kB
[mukherjees@instance-03001261 ~]$ ^C
[mukherjees@instance-03001261 ~]$

The image of the output of the the terminal is attached.

Dear @sxm3816,

Unfortunately, the answer to your question is: “No, there is no way to tell FLAIR to stop the run/cycle when say about 90% of the hard drive is filled”.

I can also offer you some unsolicited comments, which I fear would not be much of use to you.

-Fedora 32 is pretty old and not supported since more than 2 years. I would recommend to update it.

-The diskspace on the machine you’re running is very small, less than 20 GB. It is very difficult to run Fluka on such small diskspace. You can try asking your administrator for a bigger machine or check if the machine can access some other storage space.

-You can try running less cycles.

Dear amario
thanks for the reply. I am going to contact the admin for a bigger machine. and upgrade!