ERROR: executable returned RC=136, Floating-point exception

Dear FLUKA experts,

My program terminated unexpectedly when simulate muons pass through the soil.

The primary particle information was read from an external .txt file through OPEN and SOURCE cards. After run the input (neww10.inp) in flair, it crashed and finished with errors.

The neww10.out shows:

======================== Running FLUKA for cycle # 1 ========================
Error: "/home/jiang/FlukaTest/w10/aw10" executable returned RC=136

And the fluka_23043/neww10001.log shows:

Program received signal SIGFPE: Floating-point exception - erroneous arithmetic operation.

Backtrace for this error:
#0  0x7f273f1cd2ed in ???
#1  0x7f273f1cc503 in ???
#2  0x7f273e849fcf in ???
#3  0x55fb666666a4 in ???

In attachment is the related files.
neww10.inp (3.0 KB) neww10.out (575 Bytes) source(fluka4).f (9.1 KB) neww10001.err (714 Bytes) neww10001.out (76.5 KB)

Could anyone help me out, please?
Thank you in advance.

Dear Shan Jiang,

to be able to test your source routine, could you provide (a portion of) the data file you are using, and the complete backtrace from neww10001.log file?


Thanks for your reply!

I thought the size of the 2 files was too huge to upload. And now I post them in the link:

Dear Shan Jiang,

your input is working on my computer without any issue.

Could you check the output of these commands:

which gfortran
gfortran -v


Dear David,

Sorry to reply you so late.

The output:

:~$ which gfortran

:~$ gfortran -v
gcc version 7.5.0

Besides, the package of fluka is fluka_4-1.1.Linux-gfor7_amd64.deb.

Dear Shan Jiang,

that is strange. the gfortran -v command should return the configuration settings as well.

Which Linux distribution are you using?
Is the gfortran installed with package manager or is it compiled from source?


Dear David,

The complete output of gfortran -v :

And the gfortran was installed by the command sudo apt-get install gfortran if I`v got it right.

Dear Shan Jiang,

I sorry, I though your problem was related to another issue, but it seems that’s not the case.

Since I can run your input without any problem on an Ubuntu 18.04 with FLUKA installed from the .deb package, I can only think that there was an error in your source routine, you fixed it, but by mistake you forgot to recompile your executable.

Could you check if it is the case?


Dear David,

It is very strange. Just now I tried the input again without any modification. It run well and finished OK.
It seems there is no problem anymore.

Thank you so much for your help,