Error while using 218Po isotope source

Dear Fluka experts,
I want to generate radiation from 218Po and all its daughters. From what I’ve read, I understand that by using sdum=ISOTOPE in BEAM card and semi-analogue decay mode it is possible to generate beta and gamma radiation, but not alpha radiation. That would be fine for me (as I can simulate the alpha radiation separately), however when I set

HI-PROPE 84 218

I get the following error messages in the Output
Error code: 12
and in the .log file
STOP Exceeded upper dp/dx abscissa.
Note: The following floating-point exceptions are signalling: IEEE_UNDERFLOW_FLAG IEEE_DENORMAL

I also tried radionuclides 226Ra, 214Pb, 214Bi and 241Am with the same result. But with radionuclides undergoing the beta decay (131I, 60Co) the simulation runs and ends well.

Where could be a problem?

I have Fluka version 4.2.0. I attach the input and the generated files.

vstup.flair (4.0 KB)
vstup.inp (2.4 KB)
vstup.out (768 Bytes)
vstup001.err (604 Bytes)
vstup001.log (158 Bytes)
vstup001.out (76.8 KB)

Dear Michal,

not really, with FLUKA 4.2 you now get the alpha radiation too (as indicated in the release notes) … and this is actually the reason of the crash you undergo: in the (logical) absence of the BEAM energy, the upper limit of the stopping power tabulation for the alpha transport turns out to be inadequate for the 5 MeV alpha emitted by 218Po (analogously for the other decay chains implying alpha emitters).
This is a bug, whose fix is going to further enrich the 4.2.1 minor release planned for next month.
In the meantime, you can bypass the issue by setting a high transport threshold for 4-HELIUM with PART-THR.
Thanks for reporting!

1 Like