Executable returned RC=134

Hello FLUKA experts,

I’m running through the most recent course materials and have come to a near halt with the user source routine exercises: 2022 FLUKA.CERN course - Brussels (16-20 May 2022) · Indico .

I’ve seen the alternate post with a similar topic, but I’ve confirmed my gfortran and fluka versions do indeed match (gfortran 8 and fluka gfor8).

The error is the following:

============== Running FLUKA for cycle # 1 ========================
/Users/rross/Code/fluka/fluka4-2.2/bin/rfluka: line 374: 16258 Abort trap: 6           "${EXE}" "${INPF}" > "${LOGF}" 2>&1
Error: "/SomePath/2022_FLUKA.CERN_course_-_Brussels/20220519_Thursday/1615_Source_routines__Exercise/source_newgen_test" executable returned RC=134

Eventually, I’d like to define a muon source for underground experiments which would involve an anisotropic zenith angle distribution and an energy distribution to sample from.

Thank you for giving your time. This forum is most useful.


source_newgen.f (18.8 KB)
source_routine.inp (836 Bytes)

Can you please share all the relevant files, i.e. source routine and inputfile ?

Hello Amario,

I’ve amended the original post with example source_routine.inp and source_newgen.f files.

These should be exactly those from the course exercises.

Thank you

Dear @rross,
The source routine you attached worked out of the box for me.
Did you have a look at the output files? All the three of them, .log, .out, and .err.

Hi Amario,

The output files are attached. I don’t think there was a .err file.

I appreciate your help!


source_routine.out (1.4 KB)
source_routine001.log (233 Bytes)

It seems there is some library problem. You have a Mac, right?

That’s right. Running Catalina.

Dear @amario and others,

I’ve somehow solved this issue. It required creating links as follows. I do not know how this worked, only that the sim ran to completion since I’ve made these changes:

ln /opt/local/lib/gcc8/libgfortran.5.dylib /usr/local/lib/libgfortran.5.dylib
ln /opt/local/lib/gcc8/libquadmath.0.dylib /usr/local/lib/libquadmath.0.dylib

Thank you once more for your time.

All the best,