FLUKA installation issue - libc6 >=2.29 not available on Ubuntu 18.04 standard repo

Dear FLUKA experts,

I am running Ubuntu 18.04 LTS (64-bit). When following the FLUKA installation instructions for (.deb) and software requirements I encounter an error during installation as super user. I am using the advised FLUKA fluka-2011-3.0.Linux-gfor9_amd64.deb version. Gfortran 8.3 installed.

The libc6 is only available in version 2.27 on the Ubuntu standard repo via apt install. However, FLUKA requires libc6 version 2.29 or higher.

I found an online repo for the 2.29 version via .deb download (alternative to compiling from libc6 source).

However, trying to install libc6 higher than 2.27 breaks locales. Now I am not sure how smart it is to force a full libc6 replace including locales.

Is there a known, better fix for this i.e. installing a different FLUKA package? Is FLUKA currently really in need of libc6 2.29 or would 2.27 be sufficient?

Thanks for your help!

Error message:
sudo dpkg -i fluka-2011-3.0.Linux-gfor9_amd64.deb
[sudo] password for username:
Selecting previously unselected package fluka.
(Reading database … 83593 files and directories currently installed.)
Preparing to unpack fluka-2011-3.0.Linux-gfor9_amd64.deb …
Unpacking fluka (2011-3.0) …
dpkg: dependency problems prevent configuration of fluka:
fluka depends on libc6 (>= 2.29); however:
Version of libc6:amd64 on system is 2.27-3ubuntu1.

dpkg: error processing package fluka (–install):
dependency problems - leaving unconfigured
Errors were encountered while processing:

Dear @ideas-moose,

You have two options:

  1. You can install the gfortran 9 (.tgz) version of FLUKA, or
  2. Configure Ubuntu to use gfortran-7 as your compiler, and install the gfortran 7 (.deb) version.


Dear David,

I can confirm that using the gfortran9 (.tgz) version works on Ubuntu 18.04 LTS. No update of libc6 2.27 necessary.

Thanks a lot!