Geometry Errors with Lattices

Continuing the discussion from Collimator with Hole Geometry Errors:

I expanded on the design described in the previous discussion. I built a collimator grid of holes and, due to its symmetry, used lattices to split the geometry. I modeled 1/6th of it and then used lattice card to fill in the rest.

My issues is that when I run large particle numbers (10^6 or 10^7), my simulation fails with “TOO MANY ERRORS IN GEOMETRY”.

Based on the previous discussion I:

  1. Used only start_translat (as opposed to start_transform which is more prone to precision errors).
  2. I do not have any geometry errors (that I can find).
  3. I do not have any overlapping planes.
  4. The accuracy parameter in GEOBEGIN has been increased to 1e-2.

I believe I am experiencing a build up of precision errors as a result of using LATTICEs but I have implementing all of the mitigation strategies of which I am aware. If someone could take a look at my geometry and give me a suggestion on how to improve it or, at the least, confirm that I need to take a different approach such as not using lattices, I would greatly appreciate it.

Due to the sensitive nature of the design, I would prefer to share the .flair file privately.

Hi @Dirk.A.Bartkoski ,
I’ve checked your input and you are right, there are no geometry errors.
The accuracy parameters of 1e-2 is too big, leading to inaccuracies when you have thin coating surfaces like the TRG_W region.
I removed the accuracy parameter from your input and run 1e7 particles without a crash. There are occasionally some fake precision, geometry errors appearing, but the code recovers them

Thank you very much. The 1e-2 accuracy was from the previous discussion

I suppose since I changed the start_transform implementation, it was no longer necessary.