GeoView 3D viewing error

Hi, Dear experts,
when I ran my input file it closed soon and I got the below error, could anyone help me, please? I think it occurs for the 3D viewing part!

error.pdf (191.3 KB)

Hello @mosleh ,

could you try to update MacPorts?

sudo port selfupdate
sudo port upgrade outdated

Then, it may also be useful to recompile geoviewer (instructions available in “Compile from source” in this page).

Let us know if you still need assistance.
Cheers Luigi

Dear Luigi after your suggestion command I received this error

Error: /opt/local/bin/port: port selfupdate failed: Error synchronizing MacPorts sources: command execution failed

Thank you.

Hello @mosleh ,

it looks like a connection issue. Try to run the command sudo port selfupdate again.
If it persists, run with the additional option
sudo port -v selfupdate

Cheers Luigi

Hello, Dear @luillo ,
I did your suggestions but the fluke crushed again. Do you think it needs full of the disk space?

Dear @mosleh ,

it’s not a problem with disk space.
Can you send me the output of these two commands?

which c++
which g++

hi Dear @luillo

Screen Shot 2022-04-27 at 10.02.00 PM

Hello @mosleh

please change line 75 of config.mk
CXX := c++ → CXX := g++

Then go in the geoviewer folder,

$ cd flair-geoviewer-X-XX
$ make clean
$ make -j 8
$ make install DESTDIR=PATH_FLAIR

Let me know if it works.

Hello Dear Luigi

Unfortunately, it doesn’t work again!!!
We added this command before:
make DEBUG=yes
in geoviewer directory, is it could be related to this problem now?

Thank you.

Hello @mosleh

could you try to recompile without debug option?
Before run make clean in geoviewer folder

Dear Luigi,
I did it without debugging, but the geoviewer doesn’t work at all!!!
After debugging, the geoviewer opened, and when I selected the 3D window, the crash occurred.

Dear @mosleh

Can you provide the output of the following commands?
which python3
port version
port echo installed

which python3
/opt/local/bin/python3

port version
Version: 2.7.2

port echo installed
port echo installed.pdf (63.6 KB)

Hello @mosleh

I was able to reproduce your crash on my computer.
It looks like it is linked to the python version. We will need more time to find a proper solution.

In the meantime, downgrading to python3.7 works for me.
You can try these commands:
sudo port install py37-matplotlib +tkinter
sudo port select --set python3 python37

then in the geoviewer folder
make clean
make -j 8
make install DESTDIR=<path to flair>

Unfortunately, the downgrading of the python version can have some issues.
In my case, I deleted all ports with the two following commands

sudo port uninstall installed
sudo port claim (answer yes to all questions)

Before performing the previous commands, I recommend you to save the list of requested ports, which would be useful to reinstall the other ports you need with the following command
port echo requested

Please let me know if this works for you.

1 Like

Hello @luillo,
Thank you for your solution. My problem is solved now.

With Kind Regards,
Mosleh