Geoviewer problem: segmentation fault

Dear FLUKA experts,

I am trying to install flair on my new Mac book with MacOS Catalina. I’ve been running flair on my old Mac for a while but I have a trouble to install it on new machine.
I run out to the same problem of Segmentation fault as Jason Osheroff back to 20 Aug 2020. I tried to change the python to python 38 but it didn’t solve a problem.
Right now flair is opening but as soon as I press the tab Geometry the program shuts down and I get the error : ./flair: line 14: 56674 Segmentation fault: 11 {PYTHON} -O -W ignore {DIR}/ “$@”
Simultaneously I get an error window that python 3 quits unexpectedly.
What could it be?
Thank you very much .

Hello @smalko ,

could you check which python executable you are using with the following command?
which python3

It should point to the MacPorts installation, normally /opt/local/bin/python3, unless you have a non-standard installation.

If it is not the correct path, run flair with the following command
PYTHON=/opt/local/bin/python3 <path to Flair folder>/flair

I hope that this could help. Let us know.
Cheers, Luigi

Hi Luigi,

Thank you very much! It works!