Install Flair and Geoviewer in Rocky linux 8.7

Dear FLUKA experts,
I am trying to install Fluka and Flair in Rocky linux 8.7.
Fluka installation went fine, but when I tried to install Flair and Geoviewer from the rmp I got the following error message:

Started 2023.01.16 08:36:53

w> Warning: Geometry Viewer not found
e> ERROR: /lib64/ version `GLIBC_2.29’ not found (required by /usr/local/flair/

Following this thread, I think the problem is with mismatching python packages.
Can you please inform me which packages should be downloaded for Rocky 8.7?

Thank you in advance,
Hen Shukrun

Dear Rachel,

you need to install Flair-geoviewer from the .tgz package. That way during the installation your system’s GLIBC version will be used.


Dear @horvathd ,
Thank you very much for your reply.
I tried to install Flair-geoviewer from the .tgz package, and now I get the following error after typing the make or make THREAD=no commands:

make[1]: Leaving directory ‘/home/hen12340/Desktop/Flair/flair-geoviewer-3.2/xdraw’
g++ -c -m64 -g -DUNIX -std=c++11 -O3 -funroll-loops -fno-math-errno -DNDEBUG -D_DEBUG=0 -ftree-vectorize -pedantic -W -Wall -Wcast-qual -Wextra -Wformat -Wpointer-arith -Wshadow -Wno-write-strings -Wcast-align -Wredundant-decls -Wno-long-long -Wno-non-virtual-dtor -Wno-variadic-macros -Woverloaded-virtual -Wpointer-arith -Wshadow -Wunused -Wuninitialized -Wwrite-strings -Wshadow -pipe -pthread -Wno-class-memaccess -fwrapv -fstack-protector -fpic -fno-strict-aliasing -I. -I… -I/usr/include fatal error: Python.h: No such file or directory
#include <Python.h>
compilation terminated.
make: *** [makefile:310: geometryobject.o] Error 1

What should be done next?

Thank you in advance,
Hen Shukrun

Hi Rachel,

did you install the necessary extra packages listed here?