Installation error with .deb package

Hello everyone,

I am trying to install the fluka… .deb package using Ubuntu 20.04. So I typed in the command

dpkg -i fluka-…-gforXX_amd64.deb

as it is described in the installation guide. Unfortunately I am facing the error dpgk is not found and I should try ‘sudo apt install <deb name’ instead, which I did, but now I am getting a new error saying ‘unable to locate package’.

Can anyone help me? Unfortunately I do not have any experience with Linux, I tried to google and solve it, but could not help myself.

Thank you in advance,

Dear @ines.maltusch,

First you need to install dpkg using the following command line:
sudo apt-get install dpkg

After this step use
sudo dpkg -i fluka-.4.2…deb (the one that appears in your last command line)

Please let me know if you have further questions,

Dear @Mihaela_Parvu,
thank you for the fast response!
I already tried it and did it now once again, it says I already have the latest dpkg package version installed. I tried it now once again and not I get the error that it cannot access the archive.

Thank you,

Dear Ines,

Can you type ls in your terminal?
Looks like the deb file is located in another folder (maybe Downloads?). You have to type the sudo dpkg -i command inside the folder where Fluka is saved.

Dear Mihaela,

when I type ‘Is’ in the terminal it says command not found. I am a bit confused what ubuntu is using as the main directory. I haven’t installed anything from fluka yet, so I just placed the .deb file on the desktop.

Did you try ls after opening the terminal with right click on your Desktop → open terminal?

No, I opened it like this and run it as an administrator.

Dear Ines,

your commands have typos in them:

  • the correct package name is fluka_4-2.2.x86-Linux-gfor9_amd64.deb
  • the command to list the content of the directory is ls (lower-case L, not capital I).

You may want to take a look at a tutorial on Linux, like this Linux Tutorial for Beginners - Learn Linux and the Bash Command Line to get familiar with the basic commands.

The WSL Linux uses the complete separate filesystem by default. You can access your Windows drives via the Linux directory /mnt/...


1 Like

Thank you David, I got it now and sorry for the stupid typo mistakes…could have figured that out by myself :woman_facepalming: