Installation of FLAIR and the geoviewer on Mac OS Catalina with Home-brew

I’m trying to install the whole thing on Mac OS Catalina (10.15.3) but with Homebrew; not with Macport.

So far so good, I managed to compile and run everything:

  • Python 3.8.1 built from source, with a binding to the latest TCL/TK (8.6.10)
  • compilation of the geoviewer, no errors, with Apple clang: version 11.0.0 (clang-1100.0.33.17)

However, when I run flair (which starts without errors, except for missing fonts) then click “geometry”, I get a segmentation fault.

Has anyone tried the installation on Mac with Homebrew and could share how everything was compiled? If not I’ll try to provide more information for debugging.

Hi Cedric,

I don’t have a mac to test with, but first I would try to compile flair-geoviewer with gcc.


Hi Cedric,
it’s possible to compile Flair/geoviewer with Homebrew, but the program is graphically not equivalent to the Linux version.
The reason is that Homebrew leverages on the software that comes with OS X, in particular, it uses an old version of Tkl/Tc.
That’s why we recommend using Macport.
In case we find a satisfactory installation procedure with Homebrew, we will publish on
Of course, any contribution is most welcome!
Cheers luigi

Hi everyone,

Similar to Cedric, I’m using macOS Catalina 10.15.4, and I got error while click Geometry in Flair (line 15: 1120 Segmentation fault: 11 CMD @).
The number 1120 increases if I restart Flair and click Geometry again.
I used Homebrew to install older Fluka and Flair 2.3 (, I didn’t realize this new websites earlier.
But I followed instructions using Macport to install latest versions of Fluka and Flair here.
I’m not sure if I have messed up compiler versions for Flair-geoveiver, Tcl/Tk shows 8.6.10 in my Python 3.8.2.
Please advise, Thanks Johnny :slight_smile:

Hi @JohnnyC,

Do you have the same problem (flair crashes while opening geoviewer)
with the macports installation as well - or do you encounter a different issue?
In case of the same issue, could you please follow the instructions here and let us know?
In case you see different problems, could you please be more specific?
(i.e. not able to install? run? and error that appears in the terminal)


Hi Thanos,

It’s working well now!
The error code ( line 15: 1120 Segmentation fault: 11 CMD @) I got is different from that instruction, but apparently they are the same cause.
Thanks a lot,