Installation of geoviewer on Mac OS Monterey (M1) with Homebrew

Dear colleagues,
I write you concerning a question that has already been touched on this forum. Specifically, I’d like to install the Flair geoviewer on a Macbook pro (M1 CPU) with OS Monterey. However, since I already compiled and installed many other software packages using brew for the library dependencies, I’d avoid to follow the solution discussed on this forum, based on macports.
However, I was not able to find a working solution.

May I ask you if anyone has tried this and found a solution?


Andrea Celentano

Dear @acelenta ,

in the past, we made several tests with HomeBrew, but we could not find an appropriate solution
for Flair. The problem was related to the tk-tcl libraries and it resulted in a graphical aspect rather odd.
The reason is that HomeBrew leverages the libraries installed natively on the Mac, while MacPorts has a separate installation that allows more control of the libraries installed.
In short, unfortunately, I cannot provide you with any solution. I can make further investigations but it won’t be soon.
Of course, if you find a solution please let us know and post it to the forum.

Cheers Luigi

Dear Luigi,
thanks. I tried to experiment a little bit with tk-tcl, after running

brew install tcl-tk

that provides tk 8.6.12 installed in /opt/homebrew/opt/tcl-tk/. I tried to change the makefile to point to this, but for all tests that I did, either I got the error:

./flair: line 14: 26572 Segmentation fault: 11 {PYTHON} -O -W ignore {DIR}/ “$@”

or the error:

dynamic module does not define module export function (PyInit_geoviewer)

I think that for the moment I wont’ look into this further. I appreciate if, on the long term, you can also have a check into this.