Installation problem

Halo every body
I’m update fluka to fluka 3.2.0 but when I want to update to flair 3.2 I’m downloaded flair 3.2.0 and installed it and flair geoviewer 3…2.0
but when i want to lunch flair form terminal
this message appeared with me

deleted it then i re download and again installed it but the same message appeared with me
how i can solve this problem?

Hello walaa,

Have you tried to install it using the method described for Ubuntu systems?


thanks for your reply
yes I have , I used method described for ubuntu to install it

Dear @vorodin
thanks a lot for your reply
do not you have any another solution ?
I would be grateful if you had another solution

Ok, that’s fine.

Do you see the missing file in the list after executing this command?

find /usr/local/flair/manual/html/_images/flair*.gif

Should display three files

Also, could you please tell me your version of tcl/tk via the next command,

tclsh <<< 'puts [info patchlevel]' 

and tkinter

$ ipython
import tkinter

I have slightly different line numbers for functions than in your error message

Dear @vorodin
The result of the commands is

thanks for your hard work with me

Could you please also show the output of this one?

find /usr/local/flair/manual/html/_images/flair*.gif

Regarding your last screenshot, you need firstly switch to Python 3 or try to use ipython3 command
Then execute ipython commands in the order that was mentioned

  1. ipython3 (will enter IPython )
  2. import tkinter
  3. tkinter.TkVersion

This one? Manual installation

Or this:

The second option worked perfectly for me in Ubuntu 20.04.5 LTS

Dear @vorodin

this the result of the command

i Downloaded flair
then installed it by using the command

    • sudo add-apt-repository 'deb [arch=all,amd64] /'
  1. Type the command
    $ sudo apt install flair
    and flair together with all its dependencies will be installed (including flair-geoviewer, dicom etc…). The system updater will notify you for new versions.


To update the flair version either use the update-manager from ubuntu or from the command line

$ sudo apt update
$ sudo apt upgrade

and another time by using the command
dpkg -i flair_X.XX-X_all.deb flair-geoviewer_X.XX-XX_[amd64].deb

but in the two cases the same result

There is clearly something going wrong with your installation manager\Ubuntu system. The last command output supposed to look like this

And in your case, these files are not there
I would suggest updating to the newer Ubuntu 20.04 version here is an instruction

Then use these commands in order like here but for 20.04 LTS