Installing FLUKA on Windows 10 LTSB/LTSC

I just tried to install the new FLUKA version via Windows Subsystem for Linux (WSL) according to the instructions which are linked on the new FLUKA website. It failed because our institution provides Windows 10 Enterprise LTSB (current build: 1607) which only has WSL available as a beta version. Therefore, downloading the Ubuntu installation files and install Ubuntu via WSL doesn’t work. I’m afraid this problem might occur to many institutional users as the LTSB-version of Windows 10, which provides only security-related updates, is quite common for bigger institutions/companies.

Are there any alternative ways or other instructions to install the new FLUKA version on a Windows 10 Machine (e. g. through Docker or Virtual Box)?

If the download of the Linux distro is not available via the Appstore, you can download and manually install them by using one of the links you can find here:

I know. That is not the problem. Upon starting the manually downloaded Ubuntu install file I get the message: “The Windows Subsystem for Linux optional component is not enabled. Please enable it and try again.
See for details.
Press any key to continue…”
WSL, however, is enabled.

The beta version of WSL should come with a built in Ubuntu distribution, which you can start with the “bash” command in a command line. However, I’m afraid that it would be Ubuntu 16.04 LTS, which only has older, unsupported gfortran versions.

So, probably the two options remaining in your case is - as you mentioned - a virtual machine or a docker container. At the moment we don’t have instructions how to set them up, maybe in the future.

This issue unfortunately seems to be related to your installation. It’s not a general problem of Windows enterprise 10 LTSB/LTSC.

To verify your settings I’d recommend to resort to a power shell that you start with admin rights. Then you can run the following command for verification:

Get-WindowsOptionalFeature -Online -FeatureName Microsoft-Windows-Subsystem-Linux

To (re-)enable WSL run:

Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Windows-Subsystem-Linux

General WSL Troubleshooting hints can be found here:

There is the possibility to do inplace Upgrades which did the trick for me:

$ sudo -S apt-mark hold procps strace sudo
$ sudo -S env RELEASE_UPGRADER_NO_SCREEN=1 do-release-upgrade

However, one has to be aware that this needs some time!

I just completed an installation of FLUKA on a clean Windows 10 Enterprise LTSB/LTSC machine to verify once more that there is no issue with Enterprise releases. The steps to be taken are the following:

1.) Start a PowerShell session with administrative privileges and issue the following command:

Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Windows-Subsystem-Linux

Under Windows Server 2019, the following cmdlet works as well:

Install-WindowsFeature -Name Microsoft-Windows-Subsystem-Linux

2.) Reboot the system

3.) Install e.g. ubuntu 18.04 (you can find more distributions at: ):

Invoke-WebRequest -Uri -OutFile Ubuntu.appx -UseBasicParsing

4.) Unpack the distribution in the directory in which you’ve downloaded it:
Add-AppxPackage .\Ubuntu.appx

5.) Go to the start menu and search for “Ubuntu” -> launch the installation

6.) To complete the initialization of your newly installed distro, launch a new instance and you will be asked to create a new user account. This can be anything and it’s not linked to your Windows account.

With this you’re ready and your WSL Ubuntu is like any other Ubuntu installation. To install FLUKA just follow the steps indicated in the installation instructions for Linux.

Hello Chris,

thanks for your efforts. What build/version of Windows 10 Enterprise LTSB did you use?

I have tried with the two builds that I currently have available:

10.0.17763 = version 1809, released October 2018
10.0.18362 = version 1903, released May 2019

I am bound to use 10.0.14393 = version 1607 and I can confirm that it doesn’t work (yet). As I just mentioned, only a Beta version of WSL comes with this particular version of Windows 10.

In the past i successfully tried with build 16251, which was released July 2017.

I’m afraid your system is already 4 years old and several service updates have been provided by Microsoft with which WSL works just fine.

From your description I’m not sure that it’s really an issue of the beta WSL that you’re bound to use, but I rather suspect a problem of your installation regarding which you’d have to check with your local admin.