Installing FLUKA on Windows 10

Hello, I tried following the instructions explained under:
but unfortunatelly I am stuck at step 6 where it says to “Move the file to the desired folder in Ubuntu and run the script: sudo ./ "
I dont know which is the aforementioned desired folder. I created a folder inside the ubundu named it " script”, as it can be seen in the attached screenshot, and I put the file inside it, but when i try to run the command sudo ./ it says “no such file or directory”.
Thank you very much in advance!!

Dear @pchristo,

If you want to move (tough it is not necessary) the file, you should do it with the Ubuntu terminal.

Running the script in the Ubuntu terminal from any location should work.


1 Like

Dear @horvathd,
thank you for your answer. Please excuse my ignorance but when I try to run the script which I have on my desktop, I have the following issue as it can be seen in the picture:

Thank you again for helping me!
Best wishes,

Dear Pinelopi,

first you need to change the directory to where the script is, or use an absolute path to the script.

To access the Windows drives from Ubuntu, please have a look at section 5 of the guide.

The command with absolute path in your case would be:

sudo /mnt/c/Users/lopip/Desktop/


1 Like

Thank you a lot it worked ! :grinning:
Now I am stuck somewhere else. In step 7 it says “You can follow the installation steps for GNU/Linux to install the gfor9 package of FLUKA.”
I am trying to follow the instructions in
and when i do this : As superuser, type the following command on the command line to install FLUKA:
rpm -ivh fluka-…-gforXX.x86_64.rpm I get this:

I am totally lost…
Thank you a lot for helping me!

Hi Pinelopi,

unfortunately the guide is completely clear on this point, but you need to install the .tgz package of FLUKA. See:


Well it is not clear for me…First I understand that I need to Uncompress the tgz package and it is not working…I am writing tar -xvf <mnt/c/Users/lopip/Desktop/fluka-2011-3.0.Linux-gfor9.tgz> and i get that i have a syntax error…

Hi @pchristo,

Please remove the <> in your tar command.



you should remove the “<” and “>” charaters from the commands.

Also it is recommended not to install FLUKA on your desktop, a different folder would be better. My suggestion is to create the folder c:\WSL, and install it there.

It seems that you don’t have many experience with Linux in general. Probably it would be beneficial to read the first few sections of the following tutorial: