Issue regarding flair installation in Ubuntu 22.04 vbox

Dear expert,

I encountered with the similar issue ( Bash: /usr/local/bin/flair: access is denied) while installing new flair version.

My system: Windows 11
I am trying to install fluka and flair on Ubuntu 22.04 virtual box.

I tried to follow the instructions given in the thread Bash: /usr/local/bin/flair: access is denied

But this did not work for me. So, next, instead of using the .deb packages, I tried with the source flair files. I did the following:

  1. Downloaded tar files on home/riya/CERN_FLUKA
  2. Untar both the files (flair and flair geoviewer)
  3. cd flair-geoviewer-3.2
  4. make -j 8
  5. make install DESTDIR=/home/riya/CERN_FLUKA/flair-3.2

After that, when I typed in terminal flair, it showed-
flair: command not found.

Also, make install install-bin install-mime this command gave mkdir: cannot create directory ‘/usr/local/flair’: Permission denied

Do I have to use sudo here ?


Dear @riya there is a packaging problem for Ubuntu 22. All files had the wrong permission. We are currently trying to correct the problem

1 Like

Thank you @vasilis for confirming.



you can try now. we uploaded a new package

1 Like

Thank you @vasilis, it is working now. I tried with deb packages, there is no issue.

Just to understand completely, if I use the source tar files, then we have to do the following:

  • cd flair-geoviewer-3.2
  • make -j 8 (depending on the no of cores)

After that, do I have to use both the following commands or only the last one?
make install install-bin install-mime
make install DESTDIR=/home/riya/CERN_FLUKA/flair-3.2

When we use deb packages, flair file is created in /usr/local/flair.

Will this command create flair directory in the local as well ? make install DESTDIR=/home/riya/CERN_FLUKA/flair-3.2


If you omit the DESTDIR in the make install command then the default DESTDIR is the /usr/local/flair

1 Like

Thank you @vasilis for the explanation.