Logging out when trying to run FLAIR

Dear experts,

I am trying to instal flair 3.1-2 on MAC Os 10.14. I went through tutorial on http://flair.web.cern.ch/flair/download.html
When I try to run flair it does not work and when I go to folder I type ./flair I am logged out of the computer.

I am attaching the terminal output.

Thank you very much for help
flair_ins.txt (3.1 KB) flair_ins2.txt (4.2 KB) flair_ins3.txt (8.8 KB)

Dear @dgancarc,

Could you please send me the line for the alias to flair that you’ve added to your .profile file?
in addition, and in order to check that everything is/is not ok, could you add your flair installation path to your message?


Dear @manousos,

my .bash_profile contains following:

export FLUPRO=${HOME}/flukagfor
export FLUFOR=gfortran
export PATH=${PATH}:$FLUPRO:$FLUPRO/flutil
alias flair ='/Users/davidgancarcik/Downloads/flair-3.1/flair'

instalation path is:

flair-3.1 $pwd

Thank you for your time

1 Like

Dear @dgancarc

First of all, you can remove the first 3 export commands.
For fluka the only export that you need is:

export PATH=$PATH:/pathtofluka/bin

as described here

Now for the flair alias,
please remove the space that you have between flair and =

I would also advice to use the .profile of the OsX system and not the bash_profile

After fixing the space in the alias,
you have to open a new terminal for loading the correct profile
and then for running flair you just have to type:


Could you please try again after the suggestions above (specially the fix with the space)
and let me know if the problem has been solved?


Dear @manousos

I found that all the time I am running FLUKA instead CERN FLUKA, so I do not have a /bin folder. But I have already registered for CERN one.

I renamed .bash_profile to .profile, thank you for the advice.

When I deleted a space between “flair =”, I can start the flair from every directory, but it still always log me out of the system, when I execute the command. FLAIR should be opened independently on FLUKA (it will just not find path to it). So it is not still working.

Thank you for your advices

Dear @dgancarc,

Could you type:

source ~/.profile

and send me the output of it? (if any…)
Is the logging out happening only when you type flair?
I’m wandering since it’s impossible that flair logs you out.
In my view, there are still some errors in your .profile configuration that confuse the system…
If you send me the output of the above mentioned command I might be able to help you.
Otherwise, you can attach your .profile such that I could have a look.


Dear @manousos

it produces no output. And actually it logged me out before and nothing else ever did it before. But when I did it (even through I previously opened the terminal many times) it started working. Now I can start the FLAIR I can see the interface but it still says:

w> Warning: Geometry Viewer not found
e> ERROR: No module named ‘geoviewer’

So I made this (as you just adviced to @Jason_O ):

make clean
make -j DEBUG=yes > makeinfo.log

I am attaching the makeinfo.log file.

Please accept my deepest thanks

makeinfo.log (80.7 KB)

Dear @dgancarc,

The warning/error that you see is different from @Jason_O problem.
You missed the installation of geoviewer.

Please follow the instructions as provided here under the section: Mac OsX
and let me know if everything worked.

Now concerning the log out problem, is it solved at the end?
Since now you seem to open flair


Dear @manousos

I did an installation before and I did it even once again now:

geoviewer_install.txt (16.2 KB)

But it is just not working.

This logging out stuff disappeared BUT I just restarted my PC and it is not working again. Instead of logging out, when I type “flair” it freezes the terminal and nothing happens for few minutes now. I can not even quit the process only thing I can do is CMD+Q quit the whole terminal :frowning:

Before restarting it worked now it don’t …

I appreciate your guidance

Dear @dgancarc,

Concerning the geoviewer installation,
I see, from the txt file that you’ve attached, that you missed to install it.
So you have to type inside the geoviewer folder:

make install DESTDIR=< pathtoflair >

where < pathtoflair > for your case should be:


Now for the other issue, could you please uncomment any export command that you have in your .profile and keep only the alias for flair and then try again?

Cheers, Thanos

Dear @manousos

I did it as you advised, so my .profile file has a following form
profile.txt (360 Bytes)

when I execute flair command now it answers (i had to put in the file because dollar-sign makes some formatting ):

answer.txt (132 Bytes)

Thank you

Hi @dgancarc,

Please let’s go step by step:
for the logging out issue, is it ok now?
i.e. when you type flair, you’re still logged in?

Now for your other issue, I see, from your makeinfo.log file
that you’re using anaconda for python.
This might be tricky, and I’m guessing that the problem might be originating from there.
As it is advised in the flair’s website, you have to install and use (for flair and geoviewer)
versions of python3 provided by the macports.
Please follow the instructions for the installation as described in the website,
and install the packages under the “Optionally, but strongly recommended” section as well.

Let me know if this solved the issue,

Dear @manousos

I reinstalled operating system and did everything again. Now I finally do not have a problem with opening flair. But I am still unable to install geoviewer. It says “Warning: Geometry Viewer not found”. I am sending output when I “Compile from source”

geoviewer_install.txt (16.2 KB)

I also tried to compile using " Built from src.rpm" geoviewer_using_src.txt (26.1 KB)

Output is almost the same

Thank you for your reply

Dear @dgancarc,

have you issued the command
in the geoviewer directory?
Replace PATH_FLAIR with the directory path where Flair was expanded.

Cheers, luigi

Dear @luillo ,

Yes I did it. And it producing following:

flair-geoviewer-3.1 $which flair

flair-geoviewer-3.1 $sudo make install DESTDIR=/usr/local/bin/flair
/Applications/Xcode.app/Contents/Developer/usr/bin/make -C viewer
c++ -c exportlayer.cc -m64 -g -DDarwin -O3 -funroll-loops -DNDEBUG -D_DEBUG=0 -ftree-vectorize -DTHREAD -std=c++11 -pedantic -W -Wall -Wcast-align -Wcast-qual -Wextra -Wformat -Wpointer-arith -Wredundant-decls -Wshadow -Wno-write-strings -Wno-long-long -Wno-non-virtual-dtor -Wno-variadic-macros -Woverloaded-virtual -Wpointer-arith -Wshadow -Wunused -Wuninitialized -Wwrite-strings -Wshadow -pipe -pthread -Wno-class-memaccess -fwrapv -fstack-protector -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk -fstrict-aliasing -I. -I…
In file included from /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/usr/include/wchar.h:90,
from /opt/local/include/gcc10/c++/cwchar:44,
from /opt/local/include/gcc10/c++/bits/postypes.h:40,
from /opt/local/include/gcc10/c++/iosfwd:40,
from /opt/local/include/gcc10/c++/ios:38,
from /opt/local/include/gcc10/c++/ostream:38,
from /opt/local/include/gcc10/c++/iostream:39,
from …/math/bmath.h:13,
from d2layer.h:15,
from viewer.h:11,
from exportlayer.cc:9:
/opt/local/lib/gcc10/gcc/x86_64-apple-darwin18/10.2.0/include-fixed/stdio.h:222:7: error: conflicting declaration of ‘char* ctermid(char*)’ with ‘C’ linkage
222 | char *ctermid(char *);
| ^~~~~~~
In file included from /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/usr/include/unistd.h:525,
from …/os.h:115,
from exportlayer.h:11,
from exportlayer.cc:8:
/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/usr/include/_ctermid.h:26:10: note: previous declaration with ‘C++’ linkage
26 | char *ctermid(char *);
| ^~~~~~~
make[1]: *** [exportlayer.o] Error 1
make: *** [viewer/libviewer.a] Error 2

flair-geoviewer-3.1 $flair

w> Warning: Geometry Viewer not found
e> ERROR: No module named ‘geoviewer’
Fontconfig warning: ignoring UTF-8: not a valid region tag

Thank you for fast reply

Dear @dgancarc,

If I’m not mistaken, your system is OsX Mojave.
If so, did you try to install the header files by executing the following:

sudo installer -pkg /Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.pkg -target /

After the installation of the above package,
then please execute (inside the folder where geoviewer was expanded):

make clean
make -j DEBUG=yes

For your case, I see that you’re trying to install geoviewer under /usr/local
If so, then the last command should be executed as super user


1 Like

Dear @manousos

I was not able to run FLAIR in OsX Mojave, so I just because of this updated to OsX Catalina. Because of this fact I could not find these headers. I tried to google what to do.
I found that this command should show me where the packages are now
xcrun --sdk macosx --show-sdk-path
and it answers:
So I tried to change your command according to this response but I think it was unsuccessful.

So then I tried your commands and unfortunately it did not help. I am sending the output.

log.txt (135.7 KB)

Thank you!

Dear @dgancarc

it appears that the macports headers are conflicting with the x-code ones.
for start, could you send the output of:

port echo requested


Dear @manousos,

Thank you for your help

note: I had to replace @ with at

brotli. at1.0.7_0
gcc5 at5.5.0_5
gcc6 at6.5.0_5
gcc7 at7.5.0_1
gcc9 at9.3.0_2
gcc10 at10.2.0_1
gdb at8.3_0
gdb at9.2_0
ghostscript at9.27_1+x11
ghostscript at9.52_0+x11
gnuplot at5.2.7_0+aquaterm+luaterm+pangocairo+wxwidgets+x11
gnuplot at5.2.8_0+aquaterm+luaterm+pangocairo+wxwidgets+x11
libgcc10 at10.2.0_1
libunwind-headers at5.0.1_0
putty at0.70_0+gui
py37-numpy at1.19.1_0+gfortran+openblas
py37-Pillow at6.2.0_0
py37-Pillow at7.2.0_0
py37-pip at19.3_0
py37-scipy at1.3.1_1+gfortran+openblas
py37-tkinter at3.7.5_0
py37-tkinter at3.7.9_0
python37 at3.7.9_0
python37 at3.7.9_1
xorg at20090316_0
xorg-server at1.20.5_0
xorg-server at1.20.9_0
xterm at359_0

Dear @dgancarc,

Could you please run the following:

sudo port install pkgconfig py37-matplotlib +tkinter

and try to compile again (inside the folder where geoviewer was expanded):

sudo port select --set python3 python37
sudo port select gcc mp-gcc9
make clean
make -j DEBUG=yes