MGNDATA: ERROR Field BEND not found or in not correct order

Dear Daniele,

thank you for the solution. I was able to make it work for a single field, but now I ran into another wall. If I try to define multiple fields via MGNDATA
test_MGNDATA_2x.flair (2.2 KB), FLUKA stops again this time with
ERROR Field BEND not found or in not correct order

The card order in the .out file does not correspond to the order in my .inp file, so it looks like this issue is connected to the recent fix to MGNDATA and MGNFIELD card order.

Best regards

Dear Roman,

Given the error message, I would tend to agree with your guessing.
Which version of fluka are you working with? (Is it the most recent one?)

If possible, could you attach a *.out output file?


   FLUKA Version 4-2.2        by CERN   DATE:  9/15/22    TIME: 15:29:26

   MD5SUM      : e66bd72b92fc56cf47edc30ca0d38f9d
   SHA256      : 1301ebc40bb8ab27a648ba68581f78b664bf613d
   COMMIT DATE : 2022-03-02 16:10:00 +0000               
   DPMSHA      : 006a88dc43741d46f75e14c9df0bfc11265d1812

test_MGNDATA_2x001.out (10.6 KB)
test_MGNDATA_2x.inp (2.1 KB)

Hello Roman,

this seems to be a legit bug. Can you try again with the new release (4-3.0)?
It should have solved the problem.


Dear Daniele,

yes it works with 4-3.0, thank you