Missing clipping-plane lines

I want to practice “rendering”. When I launch Flair with either my cls.inp or cls.flair files, NO dashed lines for the clipping planes are shown. See attached files.
(upload://tnSbZ1G5RmIlRMKMTrKPDk1Dg16.inp) (18.3 KB) cls.flair (17.6 KB)

Thanks, Ralph

cls.flair (17.6 KB)

Everything works for me. Clipping plane has bright green color, but it’s difficult to see it on “Media” layout. Flair version is 3.1-2 compiled from source.

Hello Ralph,

when I open your FLAIR file I get the indications of the viewing planes with the dashed lines in the different viewports (see attached screenshots). Admittedly the green might not be very visible on some screens.

If you look at the upper right corner of a viewport you can see its “associated color” and its name (I have indicated this with the circles). Those are the colors of the corresponding dashed lines which represent the viewing plane.

You can actually turn them on or off if you go to the “Layers” tab on the left side of the screen and select “Media” in the drop down box below. This will show you all the options for the 2D viewports of the type “Media” (= those showing the different materials). Below you can then find a checkbox “viewport lines” which should be checked to indicate the viewing planes in the 2D viewports. If in the first drop down box you select “3D” instead of media, you can turn on/off the visualization of the 2D viewing planes via the dashed lines in the 3D view that is displayed in the upper right of the 4 viewport windows.

Just to avoid confusion with terminology: these are actually viewing or viewport planes and not clipping planes. While the former represent a 2D section in a 3D geometry, the latter clip away parts of the geometry in the half-space towards which its normal is pointing while it leaves the other half-space untouched.

If you zoom out in the 3D viewport you can see the following:

As you can see the geometry is cut open by a clipping plane. The plane associated with the 3D port (green) is used as a clipping plane for the 3D view by default. If you grab the green dashed line in one of the other 2D viewports and drag it around you will see that this influences the 3D view by either clipping more or less of the geometry, depending on its position.
For example I moved out the clipping plane towards the camera and that way the outer shielding is not clipped anymore.

Hope that helps