No change in fluence of neutrons no matter the set up

Dear Fluka experts,

I have been trying to score neutron fluence coming out of a thin beryllium target, caused by irradiation by protons of 30 MeV. I have constructed a rather simple setup of a target, beam dump, and a polyethylene moderator. I have put a USRBDX and a USRTRACK just after the beam dump, just before the entrance of the moderator and the exit of it. Although I’m seeing some fluence, the value does not seem to change regardless of the experimental setup. I’ve tried to put a reflector on top and sides, made of beryllium, graphite etc but the simulation does not seem to change at all. Moreover, the moderator does not seem to slow down the neutrons. I only see some decrease in fluence at the end of it, but I believe that originates from the increased distance from the target, so naturally we see a decrease. It almost looks like the neutrons pass through the moderator without any interaction. There also doesn’t seem to be any collimation happening. It almost feels like no scattering of neutrons happens in my simulations. I’ve activated LOW-NEUT, EVENTTYPE All Recoils with no luck. How can I activate proper scattering processes?

fission_3.flair (6.5 KB)
fission_3.inp (4.9 KB)

Dear Egemen,

Welcome to the forum. Apologies for the delay in the reply.

Regarding the moderator, there is a substantial difference in the neutron fluence when changing the material composition of the moderator. I have tried with polyethylene (as in your original input), vacuum and lead (an extreme case). The problem I see in your input is the definition of the scoring. For instance, the USRTRACK is not showing the low energy neutrons. A suggestion is to define the card in the following way:

USRTRACK -1 NEUTRON -41 DET_AM 78.5398 100flnvlm
USRTRACK 0.03 1.0E-14 &

You will observe how neutrons are thermalized, populating the region of the spectra below 6.0e-6 GeV. The same is happening with the reflector material. You may lower down the energy range to notice the differences in the neutron fluence.

For what concerns your input, there are many cards you do not need to include:

  • Low energy neutron transport, down to thermal (1.0e-14 GeV), is automatically acivated through the “DEFAULTS: PRECISIO” card. Therefore, ‘LOW-NEUT’ nor ‘PART-THR’ for neutrons are needed. Same for ‘IONTRANS’. Please, read the documentation related to the DEFAULT card in the manual, there there is a detailed description of what it is activated when calling ‘PRECISIO’.

  • Additionally, I do not think you need ‘LOW-DOWN’ card for your physics case.

  • If you are using FLAIR, you can call DPMJET in the run tab by selecting: ‘Exe: flukadpm’. I think this is what you intended to do with the ‘EVENTYPE’ cards.

  • ‘PHYSICS’ cards: are you sure you want to activate the EM-DISSO, DPMTHRES and PEATHRESS for your problem? Read the manual to fully understand what you are activating and if it is relevant for your studies in order to optimize the simulations.

I hope these notes help you.

1 Like


Thank you for your reply. For the fluence, I’ve changed the reflector material to observe some change. Although I do see some slight changes, some differences are almost negligible, about 2-3 percent. Also, when I plot the USRTRACK with the settings you have mentioned above, energy bins tend to disappear in the lower energy spectrum. As such, I fail to see neutrons in the thermal region. Is it due to the bin size?


Indeed you will not observe much variation in the neutron fluence for the different materials of the neutron reflector. This is because the thickness of it is not optimized. The thickness of the nuetron reflector should be of the order of the diffusion length. You can find an example on how to calculate the optimum length in this exercise of the last FLUKA course:

To populate the neutron spectrum in the thermal region you may run the simulations for statistical significance. For instance, I tried with 1e8 primaries and the spectrum was populated down to 1 meV.

Thank you, your answers have been very helpful.


I’ve re-run the simulation again but I still see no moderation after the adjustments. Also, you have mentioned that you observe neutron population in 6.0e-6 GeV, but I see them in about e-11. I’ve corrected the energy range, bin size, physics cards but I still can’t see the expected results

Hi Egemen,

The reference to “6.0e-6 GeV” was related to a first test to inform you about the cut in the energy spectra in your original input. In a later comment, I mentioned that you can populate the spectrum down to 1 meV (1e-12 GeV). The spectrum you are sharing looks good to me.

I am not sure which is the issue at this stage. Could you please share your latest input files? For the exact different configurations you are trying?

Which results do you expect?

Hello again,

Shouldn’t graph shift to the left? It just seems like there is no shift in energy. I expect something like this one.

I tried without a moderator and the graph is still the same.
fission_3_R1_05.inp (5.9 KB)

Dear Egemen,

After checking your input and run several configurations, I realized that the definition of your proton beam might not be the correct one for the case you want to reproduce.

Notice that, at the moment you set a proton beam of 30 MeV which will not produce the neutron spectrum you are showing in the red curve thus the neutron spectrum in the detector will not match either the black curve.

On top of that, neutrons are thermalized in the surrounded area (in the graphite blocks).

For future interaction in the forum, please attach the input file any time there is an important modification with respect to a previous post, as it is the case in terms of geometry.

1 Like