**** No Random file available ! ****

Hi! I’m FLUKA beginner developer. When I run any .inp file in .out file there always the same error. This one

**** No Random file available !!! ****
Abort called from FLRM64 reason NO RANDOM FILE Run stopped!

What is the reason ?


without more information, it is impossible to tell, what can be wrong with your simulation.
Could you post your .inp, .out, .log and .err files? (You can attach them to a post)


When I try to attach .inp file it tells me “Sorry, new users can not upload attachments.”


please try now.


I tried. It still shows the same message.

Please log out, and log back it.


We changed the forum settings concerning the upload of files. Please try again and let us know in case of problems.

Yield.inp (5.5 KB)


your input is missing a STOP card after the START card.


Then what is the problem with this one ? basic.inp (1.3 KB)

Hi @sergey.a if you open the input Yield.inp with flair you will see several warnings/errors

  1. The MATERIAL cards are using the very old (2005) material index. Please remove all of them
    since they exist as default in fluka even the AIR
  2. There is an ASSIGNMAt card with wrong formatting (probably an additional space)
    ASSIGNMAT 10.0 5.0 7.0, which screws up the parsing of the input. Remove one space in front of the 10.0
  3. There are empty lines in the end of the file after the START which might cause problems

Your basic.inp contains 0 as number of starting particles. Please put a valid number there

Thank you very much for recommendations ! I made corrections you advise me but it still shows this message. Here is the corrected file. Yield.inp (5.5 KB)

Hi @sergey.a,

I tried to run your input with 1000 primaries, and I didn’t get any error.

Since you requested 1e9 primaries, the simulation would take a lot of time to finish, and I suspect you only see old .err, .log, .out, etc. files. Please delete everything except the .inp file, and run with 1000 primaries.

If you still get the error message, please post, your Yield.out, Yield001.out, Yield001.log and Yield001.err files, to see what could be the problem.

Kind regards,

I made corrections you advise. It starts from 003.out file. Here are them.Yield003.out (24.6 KB) Yield004.out (24.6 KB) Yield005.out (24.6 KB)

Dear @sergey.a,

We notice that you are using an older version of FLUKA (2011.2x.6). Please upgrade to the latest version available from fluka.cern (2011.3.0) - support is always provided only for the latest release. Then, try running your problem again and see if the problem persists.

Nevertheless, in the meantime, if you scroll to the end of Yield003.out you can see that the problem originates from a failure of cycle 2 to successfully complete (no random number file found), therefore please share Yield002.out as well which should be the one containing clues on the real reason for the failure.


Yield002.out (24.6 KB)

Hi @sergey.a ,

You had previously mentioned that the issue started with Yield003.out, clearly the same error message appears also at the end of Yield002.out. Please upload Yield001.out.

In the meantime it is advisable to update your FLUKA version.


Yield001.out (24.6 KB)

Dear @sergey.a,

I examined your input file without using Flair, and I noticed that the numbers are not correctly aligned. After fixing them, I was able to run your input from the command line.

If you are not familiar with the formatting requirements of FLUKA, it is highly recommended to use Flair to create your inputs.


A post was split to a new topic: Can’t download .deb package