Permission denied when runnig

Dear FLUKA experts,
I am getting the following error when trying to run a simulation:

Started 2022.04.18 16:32:30
- Running: try1-3
Dir: /home/hensh/Desktop/Input
Cmd: /usr/bin/nohup /usr/local/fluka/bin -M 5 try1-3
/usr/bin/nohup: ignoring input
/usr/bin/nohup: failed to run command ‘/usr/local/fluka/bin’: Permission denied

Error code: 126

Operating system: Ubuntu 20.04

I tried to follow the solutions on this thread , but it didn’t help.
please find the attached log files of the permissions.
Thank you in advance,
Hen Shukrun

log1.txt (1.4 KB)
log2.txt (608 Bytes)
log3.txt (574 Bytes)
log4.txt (275 Bytes)
log5.txt (5.7 KB)
log6.txt (44.0 KB)
log7.txt (2.1 KB)

Dear @rachel.hen.shukrun,
Are you trying to run fluka under your own account or some other user’s?
I don’t think this would solve the problem, but as a stab in the dark, you could try to change the ownership of the various fluka and flair files so that all of them belong to the same which means either root.root or hensh.hensh .
You can do that with the chown command, either:

 chown -R hensh.hensh /usr/local/fluka
 chown -R hensh.hensh /usr/local/flair


 chown -R root.root /usr/local/fluka
 chown -R root.root /usr/local/flair

Dear @amario,
Thank you for your reply.
I am trying to run FLUKA from the hensh.hensh user, which is my own account.
I tried to open a new input file (the basic template provided), and when I tried to run it, It seems that the ownership of the files belongs to root (although I am using the hensh.hensh user).
please refer to the following image.
What can be the cause of the problem? the input directory belongs to the hensh.hensh user, too.
Thank you in advance,
Hen Shukrun

Unfortunately, I have no clue.
On my machine Fluka is owned by root.root so that all users can run it. I always run it a simple user and never ran into such problem.