Problem in opening Flair using mobaXterm

I was trying to install FLUKA, I have followed the steps provided on the cern website. I have tried to access FLUKA using mobaXterm. When I type flair in mobaXterm to open the software it replies saying permission denied repeatedly.
I also tried using sudo flair but it says
couldn’t connect to display “localhost:10.0”


Could you Please help me out with this as soon as possible.
Thank you

Try typing sudo s first going into root and then type flair.

HI moiz muddassir,
I tried that but it doesnt work.

Hi Krish,

please check if you have the necessary permissions with the commands:

ls -al /usr/local/bin/flair


ls -al /usr/local/flair

if not, use the chmod command to grant the permissions to yourself. (Tutorial)


Dear David,
I am not able to change the properties too. Please help me with this.



The right command is

 sudo chmod 755 /usr/local/bin/flair

Hi amario,
This command changed the properties but still I’m unable to open flair.


When I try the command sudo flair, then also im unable to open it.


I think there are two different problems: one is about access rights and one about graphical interface.
Concerning the access rights, could you please post the output of the command

 ls -l /usr/local/flair

This is what I get



sudo chmod 777 /usr/local/flair

and then post the output of

 ls -l /usr/local/flair

This is what I get

then please do

sudo chmod -R 777 /usr/local/flair

then try to run flair as a standard user

this also

I dont have words to express my gratitude.
Thank you so much, its working now.