Problem with Flair | Warning: Geometry Viewer not found


Suddenly, I’ve got a strange problem with Flair. When I am trying to run Flair errors in console appear:

w> Warning: Geometry Viewer not found
e> ERROR: /usr/lib/x86_64-linux-gnu/ cannot allocate memory in static TLS block

And geoviewer is not working.

This is really strange everything was ok not so long ago. Could anyone help with that? Seems that shared library cause problem. But I am not sure why…

P.S. I am on Ubuntu 20.04, Flair (v3.0-12) was installed and re-installed few times from repository. Just a week ago everything was ok.

I never saw that error.
You could try to preload the library for testing flair

The output (if I am doing this right)

Dear Ivan,

could you check your python version with the simple python3 command?


Dear Dávid,

The version is 3.8.2.


Hi Ivan,

did you install / update anything in the last week on your PC?


Yes, I think maybe this problem is somehow related with HPLIP
I’ve tried to install, but with no luck, because this needs some deprecated libs, which Ubuntu 20.04 no longer support. Maybe this is the cause. But now I am confused about how to fix that.

Dear Ivan,

Could you try to install Flair and Geoviewer from the .tgz packages?


Dear Dávid,

I did this, with no luck =( Still the same.

Maybe file corrupted, I will try to do something with that.

Hi Guys,

I experienced the same issue, but I recalled what I had done. It happened after I installed Calibre (an e-book management environment) from Fedora 32.

I removed calibre and all dependences, and the problem was solved. Perhaps someone can identify the reason.

Here is a list of all dependences, that I removed:

calibre x86_64 4.17.0-2.fc32 updates 23 M
chmlib x86_64 0.40-22.fc32 fedora 51 k
mathjax noarch 2.7.4-6.fc32 fedora 11 M
mathjax-ams-fonts noarch 2.7.4-6.fc32 fedora 131 k
mathjax-caligraphic-fonts noarch 2.7.4-6.fc32 fedora 62 k
mathjax-fraktur-fonts noarch 2.7.4-6.fc32 fedora 138 k
mathjax-main-fonts noarch 2.7.4-6.fc32 fedora 272 k
mathjax-math-fonts noarch 2.7.4-6.fc32 fedora 126 k
mathjax-sansserif-fonts noarch 2.7.4-6.fc32 fedora 127 k
mathjax-script-fonts noarch 2.7.4-6.fc32 fedora 44 k
mathjax-size1-fonts noarch 2.7.4-6.fc32 fedora 24 k
mathjax-size2-fonts noarch 2.7.4-6.fc32 fedora 24 k
mathjax-size3-fonts noarch 2.7.4-6.fc32 fedora 16 k
mathjax-size4-fonts noarch 2.7.4-6.fc32 fedora 22 k
mathjax-stixweb-fonts noarch 2.7.4-6.fc32 fedora 987 k
mathjax-typewriter-fonts noarch 2.7.4-6.fc32 fedora 62 k
mathjax-vector-fonts noarch 2.7.4-6.fc32 fedora 13 k
mathjax-winchrome-fonts noarch 2.7.4-6.fc32 fedora 13 k
mathjax-winie6-fonts noarch 2.7.4-6.fc32 fedora 44 k
optipng x86_64 0.7.7-4.fc32 fedora 92 k
podofo-libs x86_64 0.9.6-10.fc32 fedora 646 k
python-qt5-rpm-macros noarch 5.14.2-3.fc32 updates 11 k
python3-apsw x86_64 3.32.2.r1-1.fc32 updates 366 k
python3-css-parser noarch 1.0.4-6.fc32 fedora 270 k
python3-defusedxml noarch 0.6.0-5.fc32 fedora 50 k
python3-dns noarch 1.16.0-10.fc32 updates 235 k
python3-feedparser noarch 5.2.1-14.fc32 fedora 104 k
python3-html2text noarch 2019.9.26-3.fc32 fedora 57 k
python3-html5-parser x86_64 0.4.9-1.fc32 fedora 177 k
python3-html5lib noarch 1:1.0.1-8.fc32 fedora 214 k
python3-ifaddr noarch 0.1.6-6.fc32 fedora 21 k
python3-markdown noarch 3.2.2-2.fc32 updates 135 k
python3-mechanize noarch 0.4.3-3.fc32 fedora 200 k
python3-msgpack x86_64 0.6.2-2.fc32 fedora 94 k
python3-netifaces x86_64 0.10.6-10.fc32 fedora 23 k
python3-odfpy noarch 1.4.0-3.fc32 fedora 225 k
python3-psutil x86_64 5.6.7-1.fc32 fedora 383 k
python3-pyqt5-sip x86_64 4.19.21-1.fc32 fedora 96 k
python3-qt5 x86_64 5.14.2-3.fc32 updates 1.2 M
python3-qt5-base x86_64 5.14.2-3.fc32 updates 3.2 M
python3-qt5-webengine x86_64 5.13.1-2.fc32 fedora 150 k
python3-regex x86_64 2020.5.14-1.fc32 updates 348 k
python3-webencodings noarch 0.5.1-11.fc32 fedora 27 k
qt5-qtconnectivity x86_64 5.14.2-1.fc32 updates 510 k
qt5-qtlocation x86_64 5.14.2-2.fc32 updates 3.0 M
qt5-qtmultimedia x86_64 5.14.2-1.fc32 updates 804 k
qt5-qtsensors x86_64 5.14.2-1.fc32 updates 228 k
qt5-qtserialport x86_64 5.14.2-1.fc32 updates 65 k
qt5-qttools-common noarch 5.14.2-1.fc32 updates 11 k
qt5-qttools-libs-designer x86_64 5.14.2-1.fc32 updates 2.7 M
qt5-qttools-libs-help x86_64 5.14.2-1.fc32 updates 133 k
qt5-qtwebchannel x86_64 5.14.2-1.fc32 updates 97 k
qt5-qtwebengine x86_64 5.14.2-2.fc32 updates 47 M
qt5-qtwebsockets x86_64 5.14.2-1.fc32 updates 90 k
re2 x86_64 1:20190801-4.fc32 fedora 185 k
Weak dependencies:
python3-ecdsa noarch 0.15-1.fc32 fedora 180 k
python3-pycryptodomex x86_64 3.9.7-1.fc32 fedora 1.1 M
python3-zeroconf noarch 0.26.1-1.fc32 updates 95 k

Hope this helps

I too am having this issue, just after updating to the newest FLAIR.

w> Warning: Geometry Viewer not found
e> ERROR: /usr/lib/x86_64-linux-gnu/ cannot allocate memory in static TLS block

I am runnign Ubuntu 18.04, and updated FLAIR via the sudo apt update sudo apt upgrade, so other programs were also updated as well.

Rerunning sudo apt upgrade and restarting my computer solved this issue.

Just wanted to add, that I’ve tried everything. Nothing works for me… Problem remains. Seems the only way for me is to reinstall OS.

The same errors with Fedora 32 x64 - fresh installation + Geant4.10.06.p02
I even try to install Flair and Flair-Geoviewer from sources (flair-3.1-0.tgz + geoviewer-3.1-0.tgz) with replacing “/usr/include/python3.6m/*” with “/usr/include/python3.8/” (Fedora 32 comes with Python 3.8)
and removing string “/usr/include/python3.6m/pyatomic.h” from *.d files (there is no pyatomic.h header in Python 3.8 distribution)

Started 2020.07.02 17:22:08

w> Warning: Geometry Viewer not found
e> ERROR: /lib64/ cannot allocate memory in static TLS block

Dear @igor.e.anokhin,
issue a make clean in the geoviewer directory and than continue with the usual instructions.
Let us know if this fixes the problem.

Thanks for your quick answer.
But I start from usual instructions.
Unfortunately, I received Errors described above.
Then I try to rebuild rpm from flair-geoviewer-3.1-0.src.rpm
The same Errors
Finally, I try to install it from the source.
The same Errors
No problems with Flair installation - only after Geoviewer installation the Error “/lib64/ cannot allocate memory in static TLS block” appears.
At the same time “Warning: Geometry Viewer not found” also appears (like without Geoviewer installation)

before each new attempt I remove flair and flair-geoviwer using dnf/dnfdragora and clean /usr/local/flair directory

Dear Igor,

could you try commenting out the line 194:

CXXFLAGS += -ftls-model=initial-exec

in the file of the geoviewer and recompile?


it works
at least there are no warning and error after flair starting :slight_smile:

1 Like

Kudos to @horvathd for spotting it!!
Many thanks!



Thanks, @horvathd!

Was about to reinstall my OS, but you saved me =)