Problem with Geometry Viewer installation

Dear experts,

after unsuccessful attempts to install Geoviewer on mac and centos 8, I am trying to install it on centos 7. I have tried to do it using rpm, source and tar. I am sending output of all of these.

geoviewer_rpm.txt (1.2 KB) geoviewer_source.txt (108.0 KB) geoviewer_tar.txt (19.2 KB)

Thank you for help


in your log file you can find the following error message:

/usr/include/c++/4.8.2/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support is currently experimental, and must be enabled with the -std=c++11 or -std=gnu++11 compiler options.

This indicates that you are using a GNU compiler version 4.8.2 which is > 6 years old and does not implement a lot of standard language features. Please upgrade to at least version 7.2 or higher.


Dear @ctheis

Thank you for reply! I have update already I just forgot to type “scl enable devtoolset-7 bash”. Do you think it is a good idea to add this line into .bashrc file?

But unfortunately it is still not working. I am attaching the log files.
geoviewer_tar.txt (19.9 KB) geoviewer_source.txt (74.2 KB)

With kind regards

Hi David,

Yes, I’d suggest to enable devtoolset-7 via .bashrc

In your log file you can find an error message right after trying to compile:
make: python3-config: Command not found

This indicates that you have not installed the python3-devel package.


Hi @ctheis

thank you I installed it and then I went through all these requirements and I checked it once again. And I still can not make it work any advice?

instal_log.txt (21.3 KB)

I appreciate your help

That’s very strange. It almost looks as if there are no source files. Can you check the file permissions to ensure that everyone has read access to those files?

Could you then try to run the following commands to build from the source:

make clean
make -B all


I did “chmod 777 *” in flair-geoviewer directory and then I executed your commands.
This is my output.
new_log.txt (84.8 KB)

Many many thanks

You should never do a chmod 777! With this you have given all files the “executable” (+x) flag which can create lots of trouble.

While all files should have the read flag, only directories and real executables should have the +x flag as well. Normally it should look like this:

Oh sorry, I would never expect this could cause any problems.
But I unzipped it again and it looks completely same.

So I tried to do what you advised and this is what I get:
log.txt (99.5 KB)

Thank you Chris!

Dear @dgancarc,

From your log file I see that geoviewer compiled successfully.
The problem is that you’re trying to install geoviewer under /usr/local/bin/flair.
I’m guessing that this is not the path where flair was actually expanded
but the shell script created from the rpm installation of flair for running the program.
Could you please do:

less /usr/local/bin/flair

If the output of the above will be:

“/usr/local/flair/flair” $*

then you can go to the folder where you expanded and compiled geoviewer
( in your case ~/Downloads/flair-geoviewer-3.1 )
and type:

sudo make install DESTDIR=/usr/local/flair

Dear @manousos ,

You are right, that was exactly the problem. I always find the path as “which flair” and this pointed me to the “usr/local/bin/flair” folder.

Thank you very much!