Problem with launching the new 3.0 version of Flair

I have installed Flair from deb file on my Ubuntu 19.10. And now I have troubles with launching Flair after installation. After command ‘flair’ in my console it is showing errors:

Traceback (most recent call last):
File “/usr/local/flair/”, line 89, in
import inputs
File “/usr/local/flair/”, line 22, in
AttributeError: module ‘penelope’ has no attribute ‘Penelope’

I searched for penelope module for Python 3 and found one But seems that this is not what it should be. Seems it is MC Penelope, but in the installation guide I see nothing about it. Please, help with that.

Hi Ivan

it seems there is some inconsistency in the depedencies of flair. I will fix and upload the correction in a while

Thanks! Will wait for it!

I have compiled Flair 3.0 from the source without any problem, and i don’t have neither MC Penelope nor python module for it.

I am using Debian, not the source code. Maybe it will be ok with source. Haven’t tried it yet.

Dear Vasilis @vasilis

I get the same error but there is some difference in the output.

File “/usr/local/flair/”, line 89, in
import inputs
File “/usr/local/flair/”, line 18, in
import penelope
ModuleNotFoundError: No module named ‘penelope’

Cheers, Sunil

That’s the same error, mine a bit different because I have ‘penelope’ module for Python3. If I delete this it says the same.

Dear all,

it seems like there is a dependency name problem with another python package. Maybe I would need to change the name. For the moment could you please check if the beta version I just uploaded on the web works 3.0-0b?

Yes, it works from TAR source code.

Dear Vasilis,

I can’t download it:

404 - Not found

There was an error loading the page you requested: — This page may have been deleted or moved.

Could you try now, I just copied the files on the web site


The beta version works now, the standard version still does not.


beta and standard are almost the same except the problem with the dependency.

I wanted to thank you for your work! Just installed a new version from Ubuntu repositories and everything works fine! Thanks again!

P.S. Sorry for late reply, but couldn’t answer before