Question about USRBIN

Dear FLUKA experts,I have a question when I use USEBIN to calculate PHOTON flux, the result always shows wrong.
It says :
line 0:color axis has cb coord of -1;must be above 0 for log scale!
ERROR: Gnuplot errors or warnings found.
And if I don’t selet the LOG switch , the plot will be
Can you help me please?
Many thanks for your help.
testnow.flair (3.9 KB)
testnow.inp (4.1 KB)

Dear @Nicolas_Zhou,

You need to use the RADDECAY card in semi-analogue mode and you will see also the photons.

You can also take a look at this very useful post.


Dear @Mihaela_Parvu , I cnanot understand why I need to use the RADDECAY card in semi-analogue mode. When I start a new project, it is able to show the photon flux without RADDECAY card whether it is in active mode or semi-analogue mode, but it dosen’t happen in this project.
Many thanks for your help.

Indeed the use of RADDECAY in the activation mode (WHAT(1)=1.0, Active in Flair) is the correct one in this case, where decay radiation, originated from material activation induced by the proton beam, is scored at given cooling times. The problem is still related to RADDECAY, though, since there you inhibit the prompt electromagnetic transport (see WHAT(5) in the manual) and so you cannot get any prompt photon.

Consider that your input features useless and even harmful cards: PHYSICS/PEATHRES, MUPHOTON and PAIRBREM are redundant (what they ask for is already activated by default, and in addition it’s pointless for this problem), PHOTONUC/MUMUPAIR has no point, and PHYSICS/IONSPLIT is inhibiting the use of the new deuteron interaction model, available since 2021 (FLUKA v4-2) and here switched off without any reason.
Also, note that your biasing, setting decreasing importance for more peripheral regions, is doing the opposite of what it is designed for, spoiling the statistics through the lead shielding, after increasing it only at the passage from the copper target to the A1 layer (from default importance 1 to A1 importance of 125, where anyway the importance ratio 125/1 is automatically limited by FLUKA to the maximum value of 5).

Dear Francesco,

In this case, is the use of RADDECAY card in the activation mode the same as the semi-analogue mode along with the TIME-CUT card for photons?

Hi Mihaela,

no. RADDECAY in the activation mode allows you to get the decay photon fluence rate at a given cooling time (note that @Nicolas_Zhou was actually scoring in the concerned USRBIN prompt photons, i.e. not originated by the decay of radioactive residues). In semi-analogue mode, along with TIME-CUT, you get the fluence of all photons emitted until the cutoff time. In the first case it’s an instantaneous fluence rate, while in the latter case it’s a fluence cumulated over a time interval.

1 Like

Dear @ceruttif
Thanks for your advise. I reduse the PHYSICS/PEATHRES、MUPHOTON and PAIRBREM PHYSICS/IONSPLIT card and the project dosen’t run. But when I just put the PHYSICS/IONSPLIT card back, it works again.
Can you help me with this problem?
Thank you very much

Which FLUKA version are you using? To know it, read the file Version.tag in the main directory of the FLUKA installation or press the button Updates in the first tab of Flair.
The latest versions to be used are 4-3.1 for FLUKA (Download latest FLUKA release | The official CERN FLUKA website) and 3.2-2 for Flair (Official flair site).

Dear @ceruttif
I check it and both FLUKA and Flair is the lastest version(4-3.1 and 3.2-2).

The error message you can read at the end of the 001.out file is:

 Coalescence activated and beam above BME  limit with no   rQMD

You should just use the FLUKA executable including the RQMD and DPMJET libraries: in the Runs tab of Flair, select <flukadpm> in the Exe field.