Run aborts with STOP 3500?

Dear FLUKA experts,

some of my jobs are failing with the message

Abort called from SJPCMP reason 3500?? Run stopped!
STOP 3500??

while other seeds run through without problems. I attached one failing job. The custom source was linked with ldpmqmd.

Best regards

ranSIS100_Dump_Z36_A84_Q16_E460MeVu_07001.ran (1.6 KB) ranSIS100_Dump_Z36_A84_Q16_E460MeVu_07002.ran (1.6 KB) SIS100_Dump_Z36_A84_Q16_E460MeVu_07.inp (6.4 KB) SIS100_Dump_Z36_A84_Q16_E460MeVu_07001.err (7.4 KB) SIS100_Dump_Z36_A84_Q16_E460MeVu_07001.log (134 Bytes) SIS100_Dump_Z36_A84_Q16_E460MeVu_07001.out (129.3 KB) source_twissbeam.f (11.1 KB)

It appears there are also problems with 2500:

Abort called from PHANMO reason 2500 Run stopped!
STOP 2500

ranSIS100_Dump_Z82_A207_Q26_E2600MeVu_19001.ran (1.6 KB) ranSIS100_Dump_Z82_A207_Q26_E2600MeVu_19002.ran (1.6 KB) SIS100_Dump_Z82_A207_Q26_E2600MeVu_19.inp (6.4 KB) SIS100_Dump_Z82_A207_Q26_E2600MeVu_19001.err (13.4 KB) SIS100_Dump_Z82_A207_Q26_E2600MeVu_19001.log (132 Bytes) SIS100_Dump_Z82_A207_Q26_E2600MeVu_19001.out (137.9 KB) STOP 2500

I have a FLUKA job
SIS100_Dump_Z92_A238_Q28_E275MeVu_03.inp (3.4 KB) source_twissbeam.f (11.1 KB)
(source linked with ldpmqmd)

that keeps crashing/aborting. I have tried it with my local FLUKA installation (fluka_4-1.0.Linux-gfor7_amd64.deb) and a cluster installation of my IT department (fluka-4-1.0.Linux-gfor9.tgz).

My local version fluka_4-1.0.Linux-gfor7_amd64.deb aborts with the

STOP 3500??

message reported earlier:

ranSIS100_Dump_Z92_A238_Q28_E275MeVu_03001.ran (1.6 KB) ranSIS100_Dump_Z92_A238_Q28_E275MeVu_03002.ran (1.6 KB) SIS100_Dump_Z92_A238_Q28_E275MeVu_03001.err (47.2 KB) SIS100_Dump_Z36_A84_Q16_E460MeVu_07001.log (134 Bytes) SIS100_Dump_Z92_A238_Q28_E275MeVu_03001.out (65.7 KB)

The cluster version fluka-4-1.0.Linux-gfor9.tgz on the other hand crashes with

At line 54 of file preeq/xinneu.f
Fortran runtime error: Index ‘102’ of dimension 1 of array ‘zznxse’ above upper bound of 100

ranSIS100_Dump_Z92_A238_Q28_E275MeVu_03001.ran (1.6 KB) ranSIS100_Dump_Z92_A238_Q28_E275MeVu_03002.ran (1.6 KB) SIS100_Dump_Z92_A238_Q28_E275MeVu_03001.err (22.7 KB) SIS100_Dump_Z92_A238_Q28_E275MeVu_03001.log (674 Bytes) SIS100_Dump_Z92_A238_Q28_E275MeVu_03001.out (64.2 KB)

As you can see, not only the errors seem to be different, but they also seem to encounter different problems. The cluster version fails after some 20k primaries while my local version exceeds 40k primaries.

Note: it seems the first .log file here is replaced with the one of an earlier report by the forum software since they are identical. Let me assure you that the STOP 3500?? log file of this job is indeed the same.

Thanks @rmartin. Both the STOP 3500?? and STOP 2500 crashes, related to a spin initialization issue for some unfortunate nuclei, are being solved (we may contact you privately to further test the fix with your well probing user case). As for the zznxse one, it’s a pre-equilibrium issue with a superheavy nucleus we shall address. Sorry for the inconvenience.

Dear Roman,

Thanks again for your crash reports!

All three bugs have been corrected and the respective fixes will be made available with the next minor release of the code, to take place early 2021.

With kind regards,