Running error on server

Dear experts, I encountered the following problems when running Fluka on the server. I hope you can help me solve this problems. Thank you very much.
When I ran Fluka on the server, I encountered the following two problems. One is that Fluka always runs on only one core, and cannot automatically adjust the number of cores required for operation, resulting in extremely slow operation speed (100 particles need one minute to run). Another problem is that I can’t use the plot key to draw. The error displayed is as follows.
line0:Bad format character
ERROR: Gnuplot errors or warning found

Dear @cuiyaoxuan,

I believe that you have 3 problems:

1-The plotting problem, which is impossible to diagnose with so little information.

2-The running on only one core, which depends on your submission script, which is also very difficult to solve as each cluster is set up differently, therefore I recommend you to seek the help of your system’s administrator.

3-The slow speed of your simulation, which is unrelated to the number of cluster used and which clearly depends on your simulation (its complexity, the physics settings, etc…) and it’s also impossible to comment upon not having any the inputfile.

Dear amario,
Maybe I have solved the drawing problem. But the problem of slow running still exists. In fact, I asked the administrator to check the running of the core and found that FLUKA was running on 47 cores. I only use the input file generated automatically when I create a new one, and then insert a USRBIN card. I set it to 10X10X10, but its running speed is still very slow. As you can see, 100 particles need one minute to run.

As I have already told you, it is impossible to comment on the speed of your simulation without looking at your inputfile.

ceshi.flair (1.4 KB)
Dear amario,
The input file is as you can see.

On my computer (not a cluster), it just took 0.024 seconds to run 100 primaries. Could you please also share one of your .err file?

Uploaded .err file
ceshi001.err (17.0 KB)

Dear @cuiyaoxuan,

If you look at the end of the .err file, you can find how long it takes on average to run 1 primary:

    100                     0                     1             5.7759047E-04         1.0000000E+30                 1       
NEXT SEEDS:   1A983       0       0       0       0       0   181CD    3039       0       0

It takes 5.77E-04 seconds. This is twice the time that it took me, but we have to take into account that we such small number of primaries we’re prone to statistical fluctuations.
I would say that this time per primary is a reasonable one.

I think that your “slow” results are due to some overhead process (maybe initialization of the cluster process or I/O) and not related to the simulation itself. The importance of this overhead process would decrease while increasing the number of primaries.