Running errors related to random seeds

Dear FLUKA expert, I have encountered some strange issues in my recent simulation work. After I generate a series of files in Spawn, I run these files. During the runtime, most files can run normally, but there are always a few files that display TIMED-OUT. When I clean these files and run them again, they will restore to normal. In addition, there will be at least one file running with an error message: Finished with ERRORS, which is displayed as: executable returned RC=136 in the out file. When I run the file on the terminal, they also show the error. But when I manually modify the random seed in the file that display error and run the file on the terminal, it runs normally. I don’t know why. Attached input file:
Mn.flair (6.7 KB)

Dear yaoxuan cui,
I believe that reasons for TIMED-OUT end ERRORS issues that leads to fatal crashes of runs are similar but different. Moreover, errors are installation dependent and are not fully reproducible.
Trying to run your model with colleagues, we have spotted that for MacOS and Windows(WLS) setups of Fluka, simulation crashes happen for the run#12, while for Ubuntu installation simulation runs without any issues. Probably, this difference only statistical, because different OSs uses different random seeds values (I am not sure about this).

However, I believe that origin of the problem is the geometry of the model where are many regions that “touches” (see geometry warnings), and which may lead to uncertainty with long living near thermal neutrons. Many collisions and log time requires for particles to leave region or to lost energy, and probability to get error is high. I have resolved problem “symptoms” using 2 approaches:
1 - To resolve TIMED-OUT problem, reduce time in the time-out card about 10-100 times and reduce 10 times void region radius. In this way you reduce probability to get this issue.
2 - To resolve fatal ERRORS leading to crashes, move particle of source from the boarder of regions, let say put source position Z = 0.0005 cm. This remove uncertainity in my case, so simulations runs without errors.

Nevertheless, I propose the way how to remove symptoms, not the origin of the problem. If it does not work in your case, or you need to resolve source of the problem for the future, let me know and I will consult with my more experienced colleagues.

Kind regards,

Thanks for your reply. The issue has been almost resolved. Additionally, my simulation generated an error in the Ubuntu.