SENSITIV card in optical photon production

Dear FLUKA experts,

I am trying to repeat some simulations I did with FLUKA 4.2.0, using the new FLUKA 4.3. However, I am not getting the same results and I hope you can help me understand what I am doing wrong.

The simulations involve the irradiation of a GADOX scintillator screen with monoenergetic pencil beam of X-rays. For the sake of simplicity, I am trying to reproduce the example in this older thread.

The issue pointed out in the old post was solved in FLUKA 4-2.0. Indeed, if I try to repeat the exact simulation of that post with FLUKA 4.3, I obtain 10^4 optical photons per beam particle. The problem, however, is when I introduce the OPT-PROP with SDUM=SENSITIV card.

If I understood correctly, SENSITIV card is applied at generation time. Thus, if I put the 0th sensitivity at 0.1 or at 0.01, instead of 10^4 I should have about 10^3 or 10^2 optical photon per beam particle, respectively. Is this correct?

When I run the simulation with different SENSITIV I do not get this scaling. I attach the input file and the output file for different values of SENSITIV (1, 0.1, 0.01).

Thank you very much for your precious help.
Francesco

GADOX_optiphoton_test.inp (1.6 KB)
GADOX_optiphoton_test.flair (2.5 KB)
GADOX_optiphoton_SENSITIV1.out (78.6 KB)
GADOX_optiphoton_SENSITIV0.1.out (78.6 KB)
GADOX_optiphoton_SENSITIV0.01.out (78.6 KB)

Dear FLUKA experts,

I have an update on the issue. As I had the installation files of FLUKA 4-2.1 and FLUKA 4-1.1, I tried the same simulation with those versions.

FLUKA 4-2.1: I obtain the exact same results as FLUKA 4-3.0, i.e., correct number of generated optical photons without SENSITIV, but not a correct scaling with the SENSITIV card input.

FLUKA 4-1.1: I obtain of course the same results of the older thread, i.e., wrong number of generated optical photons without SENSITIV. However, contrary to FLUKA 4-3.0, I get the correct scaling with the SENSITIV card.

I attach the output files ontained with FLUKA 4-1.1 from the same simulation of the older thread with no SENSITIV and SENSITIV 0th = 0.1 and 0.01. As shown in the output, the number of generated optical photons scales correctly.

Unfortunately, I do not have the installation file of FLUKA 4-2.0, where I think the behavior was correct.

Thank your for your support.

GADOX_optiphoton_4-1.1_noSENSITIV.txt (81.6 KB)
GADOX_optiphoton_4-1.1_SENSITIV0.01.txt (81.6 KB)
GADOX_optiphoton_4-1.1_SENSITIV0.1.txt (81.6 KB)

Thanks a lot, you have a point. News asap.

Dear Francesco,

Thanks for reporting.

Indeed, there was a lingering bug in the energy balance made available to optical photon production for local energy depositions whenever the sensitivity was not equal to 1. This bug was always there, but it was only after sub-threshold energy depositions were completed in v4-2.0 that its unfortunate effects could be felt.

A fix for this bug has been implemented, is currently undergoing testing, and will be shipped with the upcoming minor release before the end of the year.

Cheers,

Cesc (kudos to @blefebvre’s contribution and @ceruttif’s intuition!)

1 Like

Dear @ceruttif and @cesc,

Thank you for your answer!

I will wait for the minor release then.

Cheers, in the name of the Francesco trinity made in this post

Francesco

1 Like