Setting FLUKA directory

Hello David,

I am trying to configure the production server on Redhat 8.2 following testing on a standalone CentOS 8.3.
Following installation “flair”, it launches with a preferences warning:
Preferences pop always sets the
Fluka Directory = /opt/flair-3.1/fluka

This was my first incorrect instillation. I have changed the settings several times from the pop up but it never persists.
I set the fluka dir to /usr/local/fluka but it rolls back to /opt/flair-3.1/flair.
Note: there are no in the path /opt/flair .

Could there be a settings file in the ~/. path (dot path) that I should delete?


Dear Arthur,

technically there is no FLUKA directory is set, but the directory where FLUKA is installed has to be added to your $PATH.

If you installed from the .rpm package, it is done automatically via the script /etc/profile.d/ (You need to log out / log in for it to take effect.)

The FLUKA directory is automatically set as the directory where the rfluka command is found first in your $PATH.

Could it be that you didn’t remove the old FLUKA installation from /opt/flair-3.1/fluka? Or did you change the FLUKA directory in the Flair preferences?

If you did in Flair, please note, there is a bug currently that prevents saving the Flair preferences, which should be located in ~/.flair/flair.ini.


Hi David,

Thanks so much. Once I modify the ~/.flair/flair.ini. to reflect the fluka path problem was resolved.
Now the correct path persists.