Setting of multiple beam points

Dear Fluka experts,

I’m trying to study the setting method of multiple beam spots, and I created the input file according to the settings in the lecture. But when I run it, an error will be reported before the second cycle starts, I will upload my input file, and the error prompt is "*** Unknown control code: SPOTBEAM, ignored *** "

mupltiple.inp (2.3 KB)

Thank you in advance for your help.


After I updated FLUKA, it can run successfully, but the drawing result is a little strange compared with the lecture, as shown in the figure below. Is there any problems with my settings?

mupltiple.inp (2.3 KB)

Dear @nostaaal,
The picture on the slide as a color scale spanning from 10e-6 to ~5e-1, while you picture has a color scale from ~2e-11 to ~2e-2. I’m confident that if you adjust your color scale the two pictures will be more similar.

Dear Xiang,

the banding you observe on your result is caused by the incorrect scoring type you use for the USRBIN scoring. You should use the X-Y-Z type instead of X-Y-Z point when scoring ENERGY.

See note 14 at USRBIN | FLUKA


1 Like

Dear David,

I didn’t expect this mistake to make such a big difference, after changing the settings, I got the desired results, thank you for your help.


Thank you for your reply. I have solved this problem. And I will also pay attention to the drawing interval in the future.