Simulation ends with errors

Dear amario
I try set “PHYSICS” with the “EVAPORAT”. But there was an error running flair.This is my running program.
decay.flair (3.4 KB)


When your simulations end with an error, you should always look at the output files generated and look for error messages.
In your case, the file should be called “Decay001.err”.
Your input has actually 3 immediate errors. Of course, the program stops after the first one is found, therefore you’ll need to run 3 times to find them. Each of the error has an easy fix.
The first two errors are related to your definition of the material “concrete”. Have a look at this slides to understand better how materials work:
The first error is instead related to physics and will require you to add an extra physics card to fix it.

Dear experts,
I set an RADDECY card,but run error. Please experts help to see the cause of the error.
decay.flair (3.4 KB)


Thank you for your question. In general, the first starting point for debugging purposes would be to look into the generated files, especially the *.err, *.log and *.out ones. In your case, there were 2 issues:

  1. By activating the PHYSICS/COALESCE card, you also require one more card that I have added for you. Please investigate and (possibly) change the physics settings according to your needs (for more info please consult this lecture).
  • PHYSICS/IONSPLIT, ONLY to split deuterons (A=2) below 150 MeV/n.
  1. The PHYSICS/PEATHRES should be removed too.
  2. Whenever you define simple elements, you should also provide their Z number, which was missing for your Potassium (Z=19). This is not needed for compounds (e.g. concrete).
  3. Moreover, you have to link DPMJET and RQMD (ldpmqmd). You can achieve this by building an executable in FLAIR and then using it in your runs.

I attach here the updated input file.
decay.inp (4.3 KB)

Let me know if there is anything else I can help with.


1 Like

Dear @dprelipc
Thank you very much for your answer. Now my program is ready to run.
Dear Daniel i want ask to you a question,that is, I want to record the dose in a specific area over time.I use “DCYSCORE” and “USRBIN” to record the distribution of dose with cooling time. When I run flair, the results show that there is no data record(such as dose size after 300s) . Can you help me to see what is the cause.
I just start to do the relationship between cooling time and dose. There are many question. I’m really sorry.

This is my input file.
decay.flair (4.3 KB)


let me first recall some fundamental healthy measures:

Please do not create two parallel topics for the same problem, triggering different people at the same time in an uncorrelated way, in order to limit confusion and waste of time;
As stressed by @amario and @dprelipc, please take the time to look at the .out (.err and .log) file content;
Please do not play randomly with cards to overcome an error, but focus on their meaning, with the support of the manual and the training material.

Now, you are studying a case of activation by 600 MeV photons. You get zero because you commented out the most relevant physics card of your input, which is PHOTONUC. Photonuclear reactions are not performed by default and require that card to take place, this way producing radioactive nuclides.

Concerning one of the errors you previously met, it’s solved by using in the Run tab the bin/flukadpm executable instead of the default one (you can also regenerate it locally by choosing the ldpmqmd option in the Compile tab of Flair). This is because the requested coalescence process can produce light fragments (i.e. ions) that may re-interact and FLUKA stops as it realizes that the ion interaction libraries (DPMJET and RQMD) are not linked in the executable.

Concerning the various PHYSICS cards, please remove the PEATHRES and QMDTHRES ones that are not justified at all and correct the IONSPLIT one (for deuterons) as indicated on slide 15 of the lecture recommended above.

Remove the PART-THR card! Why do you want to cut neutrons off at 20 MeV?!