Some errors with Fluka and Flair. Can you help me?

Dear all, follow my errors below:

(1) Precisely, don’t is an error. But, a suggestion for the solution will very good.

========================== **WARNING**==============================
**Unable to determine SWAP space**
Please ensure a minimum of 512 MB of SWAP space.

(2) In this case, also no is a great error. I can advance only by digitizing the path of the on my PC.

Checking flair
flair not in standard directory
========================= **WARNING** ==============================
**flair found**
Please install the latest version of flair.
If it is already installed please add flair to your PATH
Possible commands (as superuser):
Fedora, RedHast, Scientific Linux, CentOS, Suse:

rpm -ivh --nodeps

Strongly recommended to install the flair repository, so you
can benefit automatically from the flair updates.
Instructions at:
Alternatively you can manually install the debian package

Download flair-3.1-13_all.deb from the

and install with

dpkg -i flair-3.1-13_all.deb

Follow the instructions on
For more information please look in the flair readme file

/ not found
Enter flair directory:


Checking FLUKA
========================== **ERROR** ==============================
**fluka not found in path nor in flair settings**

1. open flair and setup in the preferences the fluka path
2. edit your shell init script like ~/.bash_profile or ~/.tcshrc

and add in the PATH environment variable the fluka directory



I’m thinking that the solution to this error is equal to error 2. The first point already is soluted, I’m trey by

add the following line
in the ~/.profile (or ~/.bash_profile):
alias flair=‘PATH_FLAIR/flair’
and replace PATH_FLAIR with the directory path where Flair was expanded. However, this doesn’t have solved, the problem still stays.

Thank you so much!

The check program complains that it cannot find neither fluka nor flair. Did you install flair & fluka?
I presume yes, on which OS and how did you install it?
On which folder did you install it?
If you installed it on a custom folder did you add it on the path so as to be accessible from the command line?

If you have enough memory the swap space is not needed