Status: Timed-out

I simulate 4MeV neutron source in a water pool until thermalized. When running a large primary number (>100,000), Flair shows Timed-out in some threads after some cycles, however, the primaries and cycles progress is still working on the other threads.
How to overcome the issue?
system: Linux Ubuntu
Processor has 8 Threads

Hint: I ran the first thread again (the one that had the problem) after the other threads finished their work, and it worked fine and finished the work as well. I am not sure why this problem happens when they work simultaneously.

Dear @amgad.mohamed,

It is difficult to say. It could be some problem in accessing the disk.
You could try looking at the various .out .log and .err files generated for the problematic jobs if this happens again.

I looked at the files, they look fine to me, same as the others that do the proper job.
The problem exists randomly, I am not sure if the problem with my machine or the code. I will update if I discover something.

It looks like the program works fine in the background. so when the flag Timed-Out exists, it means the output file is inactive for a few minutes (I am not sure why); but pressing the button “Attach” fixes the problem and shows the right status again either Running or Finished Ok.