Why the running failed in Xe + U while no error before the running?

Dear experts,
I am using fluka to do the simulation with Xe + U, meaning using Xe beam to interact with U plate. The running will keep a couple of minites and then failed one by one(I used the spawn function, no mistake showed before the running). I thought it was beacause the amount of secondary particles has been too many, as a result, the similation failed with error in RAM. But in fact, my RAM is big enough(64GB). I tried other ways to solve it but all efforts failed. I worked on it for two weeks and can not find the mistake now.
I showed the input file in the attachment, could you help me with it? Thank you so much.

Best regards,

Xe_U1.inp (7.4 KB)
yours Jiangfeng

Hello Jianfeng,

I’ve been running your input file in my desktop machine for about 40 minutes and it is running fine. Granted, I ran for just 1 core: it appears to take up just 800 MB of RAM (you can check how much RAM each thread takes and see if you really exceed your system RAM or not, though this should not really justify a crash).

Did you download the latest version of FLUKA from Download latest FLUKA release | The official CERN FLUKA website ?

If this is the case, then kindly share the relevant .out, .err., and .log.

Cheers and have a nice weekend,

Cesc

Dear Francesc Salvat Pujol,
Thank you so much for your quick reply. I runned the case again with one core after you sent me the email last night. But it also failed this morning. I checked the RAM, about 1.2% RAM was used, so the problem may not be caused by RAM.
I used the latest version of FLUKA: FLUKA 4-1.1 with FLair3.1-13, and my linux system is UBUNTU 18.04. My server is DELL Precision 7920, with 26 cores. No error with other cases like P +Th, etc.

I upload the files produced by the case as attachment. Thank you so much for your help.
Have a nice weekend.

Best regards,

yours Jiangfeng
2021.08.21

Xe_U1001.out (99.2 KB)
Xe_U1001.log (795 Bytes)
Xe_U1001.err (714 Bytes)

Dear Francesc Salvat Pujol,
It is likely that the program stopped at the second particle just as the below figure showed.
Also, I found a big file named ‘core’ produced by fluka, which is nearly 800MB(so I can not upload it via this system).
Now I guess the problem may be caused by the system. (It is quite interesting that it also crashed in my colleague’s server.)

Best regards,
yours Jiangfeng

Dear Jiangfeng,

Thanks for your feedback.

In view of your .log file, the crash is a legitimate one, of course unrelated to the system settings. This particular crash is due to a numerical overflow which was incidentally spotted recently by one of our colleagues and is already fixed in the development branch of the code (which I was running, so I did not witness it directly) in view of a release later this year.

Meanwhile, for good measure, I’ve taken the liberty to run your input file for 100 different random-number-generator seeds. None of them exhibit your reported crash anymore, but I observe a rare crash (1/100 failed thus far) due to an index unexpectedly out of bounds which shall be investigated ASAP.

With kind regards,

Cesc

Dear Francesc Salvat Pujol,
Thank you so much for your kind help. I am new user for this powerful calculation tool, so I have been working on this for a long time. The information you provided is quite meaningful. So, I would be waiting for the new version of fluka online, aha. By the way, will the new version be released in Sep.?
You have been working on weekend helping me, that’s really kind you. I appreciate so much for that.

Best wishes!

your Jiangfeng