Can't not installed on macOS 10.15 Catalina

Hi Experts,

I’m trying to install the new version on Catalina. However, I always got errors like this:
gfortran -o /Users/shyshi/cernfluka/fluka2011-3.0//bin/fluka -L/Users/shyshi/cernfluka/fluka2011-3.0//lib -lfluka
ld: unexpected token: !tapi-tbd-v3 file ‘/Library/Developer/CommandLineTools/SDKs/MacOSX10.15.sdk/usr/lib/libSystem.tbd’ for architecture x86_64
collect2: error: ld returned 1 exit status
make: *** [/Users/shyshi/cernfluka/fluka2011-3.0//bin/fluka] Error 1

I have the latest XCode(11.3) and Catalina(10.15.2), with multiple versions of gfortran installed(8.2 locally, and 9.2 through macports). Both failed with same error.

Thank you very much for your help.

Best Regards,

It seems that you miss the ld for xcode.
What I would propose as a possible solution is the following:
Use the gfortran9.2 for mac of fluka and then in a terminal type the following:

sudo port clean gcc9
sudo port -v uninstall ld64
sudo port install gcc9
sudo port -v install ld64 +ld64_xcode

Afterwards, please follow the rest of the installation instructions that can be found here

Let me know if this helped and solved the problem


Thank you in advance. It works!