Error code 136 - cannot run FLUKA

Dear FLUKA experts,

I have a MacBook (Sonoma 14.3.1) and I had some issues installing FLUKA. Finally I used gcc11 because gcc10 crashed every time (FLUKA installation error)

The problem I am facing now is that every time I try to run it, it comes up with the following error in the .out file:

The .log file comes up with this:

I get the same errors even if just try to plot the geometry. I even tried the flair tutorial file just to be sure that there is nothing wrong with my input files.

Could you please advise on that? Thank you very much for your time.

Best regards,

Dear @Panos13

it may be the the MacPorts environment is corrupted.
Maybe you can try to wipe all installed ports and reinstall.

Please give a look at this thread

And let us know if it works.
Cheers Luigi

Dear Luigi,

Thank you for your reply. I did the following steps as described in the link you suggested:

sudo port uninstall installed
sudo port install gcc11
make clean

I also reinstalled flair. I still get the exact same error messages, I cannot run any file. Just checking, Is the following path correct?


Many thanks,

Dear @Panos13

the variable PATH looks correct.

In the directory <FLUKA path>/example/, could you test the FLUKA installation by running this command ?

../bin/rfluka example.inp -M1

Please report about any message in the files *.out , *,err and *.log.

In order to reproduce the issue on my side, can you provide more details about your environment with the following commands?

xcodebuild -version
which g++ gcc gfortran ar

Cheers Luigi

Dear Luigi,

I run “…/bin/rfluka example.inp -M1” and the terminal gives me this:

The example001.out is blank and the example001.log says this (no .err file is created):

I run the commands you asked with the following results:

xcodebuild -version

Xcode 15.2
Build version 15C500b


volume: /
location: /
install-time: 1708872593

which g++ gcc gfortran ar


Many thanks,

The problem was resolved through a private exchange.

The issue arises from the fact that “gcc11 is known to fail" on the latest OSX systems, as warned by MacPorts at the installation.

To resolve this, rather install gcc12 or later.

1 Like