FLUKA installation error

Dear FLUKA experts,

I am trying to install the latest version 4-4.0 on my MacBook (Sonoma 14.3.1). I have followed all the steps described in your website, but when I try to execute “make” on the terminal I get the following errror.

I repeated the steps but same things happens. Any advice on this please?

My gcc version is the following (if that helps).

Thank you,

Dear Panos,

you are likely missing the zlib library.



Dear David,

Thank you for your prompt reply. Apologies for my late response, I was trying to install FLUKA. I tried to install zlib from the link you provided but that did not fix the problem, I got the same message. I repeated the whole process but this time I installed gcc11 instead of gcc10. Do you think this will be an issue? It looks like it is installed now but now I have the following problems. When I type flair on the terminal I get this message:

Despite this message flair starts normally and I managed to run some very simple input files (its interface looks a bit different though, small and cramped). The problem now is that when I click on the geometry tab flair crashes and closes down.

Thank you,

Dear @Panos13

From the OS version, I assume that you have an Apple chip. In that case, to compile FLUKA, you need at least gcc12, as indicated on the FLUKA website.
(We will update the information on the Flair website.)

For Flair, could you please provide the output of this command?
port select --summary

Kind regards Luigi

Dear Luigi,

I don’t think I have an Apple chip:

Screenshot 2024-02-22 at 15.46.47

I run the command you asked and I get this:

Thank you,

What is the output of the command?
which python3

can you open a new Terminal and test Flair from there?

Same thing happens

Hi @Panos13,

I noticed a potential issue: you seem to be using the native Python instead of the one from MacPorts.
Typically, when you install MacPorts, the configuration file of your shell is updated to include the directories where MacPorts installs executables in the PATH environment variable. However, it seems that something went wrong.

In the same Terminal, try running this command first:

export PATH=/opt/local/bin:/opt/local/sbin:$PATH

and then, test flair again.

Hi Luigi,

Thank you for your help. This actually helped, FLUKA now appears normal and it does not crash when I click on the geometry tab. I noticed however that in the dice tab some files are missing:

I resolved this issue with setting python3 as python38:

I run some basic files with no problems. Some runs with more complicated proton sources returned the following error:

But my understanding is that this has to do something with the input file and not FLUKA. What do you reckon?

Thank you again for your help,

Hi @Panos13

For DICOM, both Python 3.8 and 3.12 should work, but you need to install the Pydicom library as indicated in the Flair banner and on the Flair installation webpage for Mac.
(EDIT: Actually, for Python 3.12, I see that there is no corresponding port for pydicom yet. A solution would be to install pydicom via pip, but the simplest option is to downgrade the Python version as you did).

For the FLUKA error, please check the messages in the files *.out, *.log, and *.err."

Hi Luigi,

Thank you for your help. Since I can run some files with FLUKA and it does not crash, I believe FLUKA and Flair are working properly now. So for now I will go this (maybe in the future I will get rid of Python 3.12 and try to reinstall everything).

I believe the FLUKA error has to do with the input files, I cannot understand from .out and .log files. Anyway if I cannot fix it I will create another topic regarding this error.

Thanks again Luigi,