Flair command line processing

Dear flair users,
I am trying to process files from multiple runs using command line. For example, I have a test.inp file part of test.flair project, with USRBIN and USRBDX scoring.
After running
rfluka -M 5 test.inp
I find all the fort files as a result of the run.
I have the last version of flair. I can process the files from the UI and create the bnn and bnx files.
But I am interested to batch process a high number of files, so I made a test and run the following from the directory where both inp and flair files are located:
flair --data test.inp test.flair
The issue is that I can’t find any processed files - I am expecting test_21.bnn and test_24.bnx etc.
This happens of two machines, one running fluka from Ubuntu in Windows10, the other one running on Fedora.
Could you tell me what am I missing?

Dear Catalin,

please have a look at this thread:


Dear David,
I hoped to use the info from this thread
Command line data processing - Flair - FLUKA User Forum (cern.ch)
and I wanted to know if this solution is still working - I mean using flair --data file.inp file.flair.
It looks that I have to use your suggestion.
Best regards,

This command works; try removing the .inp in the file.inp in your command but keep the full file.flair part.

Hi, Sunil, thanks for your suggestion.
I have tried all the combinations, but still not find a working solution. I have attached c opy of the commands, maybe I am wrong somewhere…?
Best regards,

Hi Catalin,
I see that you have tried all options, but this is strange since I have been using that feature since the version number that I mentioned in the original post. Are you using the latest version of flair? What estimator is associated with fort.21?

On Ubuntu / Windows 10 I have the latest version of flair, on Fedora is version 3.2, both have the same issue. Unit 21 is for scoring USRBIN. On Ubuntu the result is launching the GUI with test1.flair.
Best regards,

Can you try this?
Run the “checkrun” input in the flair file. Once FLUKA run is over, in the terminal, run
flair --data checkrun testflairdata.flair
You should get all the processed data files.

testflairdata.flair (1.8 KB)

This one worked. But I have to launch the execution using the flair GUI, which is not saving time like launching command line jobs from a batch file.
By the way, using flair --plots test.flair for graphs works great. The issue is only with the --data option.
Thanks anyway!

Thank you @cborcia indeed it was a small bug that now it is fixed. It will appear in the next release of flair

Thanks Vasilis, it will be of great help. I appreciate all your work for the fluka community.
Best regards,