Flair crash (seg fault, core dumped) - Ubuntu 20.04 LTS

Dear all,

I installed the newest Flair and FLUKA versions from the website, and I have run into the following issue. Flair starts up fine, and I can load up an “empty.inp” example file just fine. When I then add a volume to the geometry (say an RPP) I get the little red error box in the bottom right, and Flair promptly crashes, with the message: Segmentation fault (core dumped). It is a reasonably fresh install within a new VM.

I have tried the following things:
-Use flair from the downloaded archive instead of through apt
-Use the fluka archive for gfortran 7 and 9, compiled with the relevant compiler

If you need any further information to help me with this, please let me know and I will do my best to supply it as promptly as possible. Thank you for your help!

Hi Maarten,

Please have a look here

If you’re running in a VM you might be running into the same issue which should be fixed in a future release.


Hi Chris,

Thanks a lot for your help, this indeed solved my problem! Now I can happily run simulations again :slight_smile: thank you!