Flair crashes when clicked on geometry

I recently installed fluka and flair, with all the prerequisites on my Macbook Air M1 (Monterey) but flair seems to crash when I click on geometry tab.

FlairgeoviewerError.txt (39.1 KB)

Thank you in advance.

Dear Anil,

please take a look at this topic:


Dear Anil,
do you have also any error reports in the Terminal window?
Did you follow library installation recommendations from Official flair site ?

Kind regards,

Dear David,

I’ve tried the solution but the same error continues, flair still crashes when clicked on geometry tab.

flair: line 14: 9857 Bus error: 10 {PYTHON} -O -W ignore {DIR}/flair.py “$@”

I’m not getting segmentation fault 11 as it can be the different thing from the topic you’ve sent.

Thank you in advance.

Dear Illia,

flair: line 14: 9857 Bus error: 10 {PYTHON} -O -W ignore {DIR}/flair.py “$@”
this is the error report in the Terminal window.

And yes I’ve followed library installation recommendations from the link. I’ve also tried switching python versions to 3.7 , 3.8 from 3.10 but none of them seem to work for me.

Thank you for your time.

Dear @anil_azkin ,

as pointed by Dávid, the solution provided here works for M1 chip.

For your convenience, I report here the instructions
make clean
make -j 8 DEBUG=yes
make install DESTDIR=<path to flair>

and be sure that the geoviewer.so file inside the Flair folder is the same as in the geoviewer folder.

Sometimes MacPorts installation might be corrupted, so a more drastic approach would be to clean the installation
sudo port uninstall installed
sudo port claim (answer yes to all questions)

and then reinstall python3.7
sudo port install py37-matplotlib +tkinter
sudo port select --set python3 python37

Before performing the previous commands, I recommend you to save the list of requested ports, which would be useful to reinstall all other ports previously installed
port echo requested

If you still have problems, can you provide the output of the following commands:
which python3
port select --summary
c++ -v
and share the again the error log (it can be removed from Console application among Crash Reports?

Cheers Luigi

Dear Anil,
a couple of weeks ago, I had identical problem while tried to update FLUKA. Before, I got stacked with the problem to install required Fortan version. After the last update of the Fortran distribution, so latest versions can work with Intel chips and Monterey MacOS version this problem has resoled, but I suppose that my FLUKA environment got damaged by attempts to reinstall it.
As I understand, in my case this problem appeared when FLAIR starts using the Python interface library (tkinter) without Xming server.
In my case, it was because I use Anaconda Python installation, so some libraries are installed within this environment. I have resolved the issue by reinstallation of all required and suggested libraries, and reinstallation of Python libraries using “pip uninstall/install” (port install should also work) from the terminal, instead of “conda install” utilities.
Then I reinstalled geoviewer.


Hello @illia.zymak,

a possible solution is to use explicitly version from MacPorts.

PYTHON=/opt/local/bin/python3 <path to flair>

This allows to take all dependency libraries from MacPorts.

Cheers, Luigi

Dear Luigi,
yes! Exactly, thank you for posting explicit command. With my post I just tried to explain, that in some cases it is possible to have Python installed at your machine with all libraries, but it will not work in FLUKA due to different environments. So, It is important to configure environment used by FLUKA using e.g. MacPorts.